[GE users] rcmd: socket: Cannot assign requested address

John_Tai John_Tai at smics.com
Wed Jan 19 01:02:11 GMT 2005


    [ The following text is in the "gb2312" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

<<I assume you verified all master daemons qmaster, scheduler and
berkeley_db_svc were shut down orderly before you tried to restart.
Is this correct?>>

I shut down the daemons using the rc scripts:

/etc/init.d/sgebdb stop
/etc/init.d/sgemaster stop

Is there an order in which I have to shut them down?

<<With current 6.0 berkeley_db_svc logging is not yet used. We have to
change this. I explain the workaround with the related issue >>

Good to know, thanks.

Now that I am using classic spooling, I still have this problem though, sometimes. And I can't pinpoint the cause of this. As I stated in my previous e-mail:

qrsh -verbose
waiting for interactive job to be scheduled ...
Your interactive job 11117 has been successfully scheduled.
Establishing /home/edamgr/GridEngine/sge6-1/utilbin/sol-sparc64/rlogin session to host dsl20 ...
rcmd: socket: Cannot assign requested address
/home/edamgr/GridEngine/sge6-1/utilbin/sol-sparc64/rlogin exited with exit code 1

This is the qmaster messages:

01/17/2005 15:07:32|qmaster|dsfileserver|W|job 11117.1 failed on host dsl20 assumedly after job because: job 11117.1 died through signal KILL (9)

Any more ideas where the problem might be? Sorry to drag this for so long.

Thanks

John




More information about the gridengine-users mailing list