[GE users] integrating gridengine with lmgrd

Haim Ashkenazi haim at babysnakes.org
Thu Jan 27 12:55:15 GMT 2005


    [ The following text is in the "X-UNKNOWN" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Hi

I've started using grid a few days ago. installation was easy and I'm
able to run simple jobs...

the problems begin when I try to integrate the grid with with FLEXlm.

I've followed the howto (http://bioteam.net/dag/sge-flexlm-integration/)
and the first step was very easy (Grid Engine Complexes & Resources).
the problems started when I tried to use load_sensors. I've setup the
perl script with the wrapper so it produces this output:

global:License_A:23
global:License_B:16
global:License_C:25

I've setup the complexes:
#name               shortcut   type        relop requestable consumable default  urgency
#----------------------------------------------------------------------------------------
License_A           v1         INT         <=    YES         YES        0        0
License_B           v2         INT         <=    YES         YES        0        0
License_C           v3         INT         <=    YES         YES        0        0

and added the path to the wrapper script in the load_sensors of the
global cluster (I also tried setting it to only one host, but the result
is the same).

but when I run 'qhost -F License_A,License_B' I don't see it the result:
HOSTNAME                ARCH         NCPU  LOAD  MEMTOT  MEMUSE  SWAPTO  SWAPUS
-------------------------------------------------------------------------------
global                  -               -     -       -       -       -       -
wint19                  sol-sparc64     1  0.02  512.0M  123.0M 1000.0M   36.0M
wint21                  sol-sparc64     1  0.17  512.0M  264.0M 1000.0M  248.0M

using the 'tmpfree' example from
"http://gridengine.sunsource.net/project/gridengine/howto/consumable.html" I could see the free '/tmp' space on all the computers, but when changing just the link to the load_sensors script (and adding the License_X variables) I can't get the number of licenses.

any ideas?

thanx
-- 
Haim


    [ Part 2, "This is a digitally signed message part" ]
    [ Application/PGP-SIGNATURE (Name: "signature.asc") 196 bytes. ]
    [ Unable to print this part. ]



More information about the gridengine-users mailing list