[GE users] StartPVM can't start slave pvmds

Reuti reuti at staff.uni-marburg.de
Fri Mar 18 19:33:46 GMT 2005


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi,

interesting: in the last couple of days there is again a demand for PVM on this 
list. I'm just looking into it, to get a tight integration with SGE (the pvmds 
have to be children of the shepered, not just to be started by rsh). But 
anyway:

- PVM on it's own is working, when you start the daemons from the pvm console?
- rsh is possible between the nodes?
- What is the content of your /remote/temp_pe_hostfile

Cheers - Reuti

Quoting Sili Huang <shuang at unb.ca>:

> Hi,
> 
> I am experiencing problems in getting PVM 3.4 integeraded with Sun
> Grid Engine 6.0. Does anyone met this problem and solved it before?
> 
> StartPVM reports errors when bringing up the slave pvmds:
> startpvm: Couldn't get all of the 2 requested hosts
> startpvm.sh: startup failed - invoking cleanup script.
> 
> When I am trying to run StartPVM manualy for testing, it reports that:
> [root at v60-n05 root]/remote/general/sge/pvm/bin/lx24-x86/start_pvm -h 2
> /usr/share/pvm3/lib/pvmd /remote/temp_pe_hostfile
> /tmp/pvmtmp023986.0
> start_pvm: enrolled to local pvmd
> start_pvm: got 1 of 2 hosts
> start_pvm: 262144 v60-n05 LINUX 1000
> start_pvm: got 1 of 2 hosts
> start_pvm: 262144 v60-n05 LINUX 1000
> start_pvm: got 1 of 2 hosts
> start_pvm: 262144 v60-n05 LINUX 1000
> start_pvm: got 1 of 2 hosts
> start_pvm: 262144 v60-n05 LINUX 1000
> start_pvm: got 1 of 2 hosts
> start_pvm: 262144 v60-n05 LINUX 1000
> start_pvm: got 1 of 2 hosts
> start_pvm: 262144 v60-n05 LINUX 1000
> start_pvm: got 1 of 2 hosts
> start_pvm: 262144 v60-n05 LINUX 1000
> start_pvm: got 1 of 2 hosts
> start_pvm: 262144 v60-n05 LINUX 1000
> start_pvm: got 1 of 2 hosts
> start_pvm: 262144 v60-n05 LINUX 1000
> startpvm: Couldn't get all of the 2 requested hosts
> 
> Note that there was not orphaned pvmd and /tmp/pvmd.* files in the two
> nodes.
> 
> Thanks.
> 
> Best regards,
> 
> Wesley Huang
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list