[GE users] PVM and Grid Engine 6.0

Reuti reuti at staff.uni-marburg.de
Mon Mar 21 16:19:45 GMT 2005


Hi Patrice,

first of all, I got a also a Tight Integration of PVM working and will 
put it now in a Howto, up to next week it should be available (in 
contrast to the supplied Loose Integration).

But back to your problem: did you made any decision of moving to MPI or 
solved the problem of the failed startup? Where were the output

 > NHOSTS=2
 > c0a8007d:8038

coming from, and what looks your PE definition like? - Reuti

Patrice Hamelin wrote:
> Reuti,
> 
>   I think I'm about to ask that user to convert his code to MPI!  Ok! 
> Here is what I have while trying to run the very simple "hello.c" 
> example from the PVM 3.4 distribution:
> 
> output file:
> 
> [phamelin at stokes phamelin]$ cat PVM_TEST.po5061
> -ep /usr/local/bin 
> /opt/sge/default/spool/host125/active_jobs/5061.1/pe_hostfile 
> host125.clumeq.mcgill.ca /opt/pvm3
> NHOSTS=2
> c0a8007d:8038
> startpvm.sh: startup failed - invoking cleanup script
> /opt/sge/default/spool/host125/active_jobs/5061.1/pe_hostfile 
> host125.clumeq.mcgill.ca
> 
> 
> 
> error file:
> 
> [phamelin at stokes phamelin]$ cat PVM_TEST.pe5061
> [pvmd pid2388] 02/22 13:59:20 mpp_init() PROC_LIST must be set for 
> parallelism.
> [pvmd pid2388] 02/22 13:59:20 0 nodes in list.
> libpvm [pid2387]: pvmbeatask() pvmd didn't validate itself
> libpvm [pid2387]: pvmbeatask() pvmd didn't validate itself
> libpvm [pid2387]: pvmbeatask() pvmd didn't validate itself
> libpvm [pid2387]: pvm_mytid(): Can't contact local daemon
> .
> .
> .
> libpvm [pid2387]: pvmbeatask() pvmd didn't validate itself
> libpvm [pid2387]: pvmbeatask() pvmd didn't validate itself
> libpvm [pid2387]: pvmbeatask() pvmd didn't validate itself
> libpvm [pid2387]: pvm_mytid(): Can't contact local daemon
> start_pvm: Couldn't enroll to pvm
> libpvm [pid2396] /home/tmps/pvmd.646: No such file or directory
> libpvm [pid2396] /home/tmps/pvmd.646: No such file or directory
> libpvm [pid2396]: pvm_halt(): Can't contact local daemon
> libpvm [pid2399] /home/tmps/pvmd.646: No such file or directory
> libpvm [pid2399] /home/tmps/pvmd.646: No such file or directory
> libpvm [pid2399]: pvm_halt(): Can't contact local daemon
> 
> 
> Reuti wrote:
> 
>> Hi there,
>>
>> we used PVM it many years ago, but all the software we use switched to 
>> MPI - so we have no PVM any more. But I think the way starting it 
>> stayed the same: start the daemons, run the job, stop the daemons.
>>
>> So in small steps:
>>
>> What version of PVM are you using?
>> You can run it interactively without SGE?
>> You compiled the stuff in the $SGE_ROOT/pvm/src directory?
>> You allow rsh/ssh between the nodes?
>>
>> What problems you encounter in detail?
>>
>> Cheers - Reuti
>>
>>
>> Patrice Hamelin wrote:
>>
>>> Hi,
>>>
>>>   Anybody did implement PVM under SGE?  Any hints would be really 
>>> helpfull.  I'm pulling my hair on that stuff!  I read many docs on 
>>> the subject, Readme files, etc, and I hacked startpvm.sh, tried to 
>>> run it interactively.
>>>
>>> Thanks.
>>
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list