[GE users] qmon doesn't work on RHEL4

Tim Harsch harsch1 at llnl.gov
Thu Mar 24 21:01:29 GMT 2005


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

That may explain the differences.  It looks as if you are picking someone
else's prebuilt RPMs, not one provided by the gridengine folks....


----- Original Message ----- 
From: "Vijay Avarachen" <vavarachen at gmail.com>
To: <users at gridengine.sunsource.net>
Sent: Thursday, March 24, 2005 11:42 AM
Subject: Re: [GE users] qmon doesn't work on RHEL4


> Tim,
>       I am running sge-6.0u3-2 (prebuilt bins from
> http://www.linux.duke.edu/~agrajag/RPMS/
> The hardware is dual PIII 866, 1 G RAM on each node, 3 SCSI drives
> running RH 9.0 (with no updates).  I tried to download the src rpm and
> rebuilt the rpm, but it failed with strange errors.
>
> Vijay Avarachen
>
>
> On Thu, 24 Mar 2005 11:27:31 -0800, Tim Harsch <harsch1 at llnl.gov> wrote:
> > I'd be interested to know how come your qmon links to
> > /usr/X11R6/lib/libXm.so.3 when mine doesn't....
> > I'm on a Dell Optiplex 280 ( P4 3.6Ghz), RHEL4 and SGE6.0u3 installed
via
> > prebuilt libraries....
> >
> > Can you tell us arch and SGE version for your setup?
> >
> > ----- Original Message -----
> > From: "Vijay Avarachen" <vavarachen at gmail.com>
> > To: <users at gridengine.sunsource.net>
> > Sent: Thursday, March 24, 2005 11:22 AM
> > Subject: Re: [GE users] qmon doesn't work on RHEL4
> >
> > > Nitin,
> > >       Do you know why I get the following error when I try to run
qmon:
> > > [root at spduslisclust01 rpm]# qmon
> > > qmon: relocation error: qmon: undefined symbol: _XmStrings22
> > >
> > > I have the following openmotif packages installed:
> > > [root at spduslisclust01 rpm]# rpm -qa | grep openmotif
> > > openmotif-devel-2.2.2-14
> > > openmotif-2.2.2-14
> > > openmotif21-2.1.30-8
> > >
> > > Here's some ldd info:
> > > [root at spduslisclust01 rpm]# ldd `which qmon`
> > >         libXltree.so => /usr/share/sge/lib/lx24-x86/libXltree.so
> > (0x40017000)
> > >         libdl.so.2 => /lib/libdl.so.2 (0x4002a000)
> > >         libXm.so.3 => /usr/X11R6/lib/libXm.so.3 (0x4002d000)
> > >         libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4 (0x40276000)
> > >         libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x40285000)
> > >         libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x402d7000)
> > >         libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x402e6000)
> > >         libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x402fc000)
> > >         libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x403db000)
> > >         libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x403e4000)
> > >         libXp.so.6 => /usr/X11R6/lib/libXp.so.6 (0x403fb000)
> > >         libm.so.6 => /lib/tls/libm.so.6 (0x40403000)
> > >         libpthread.so.0 => /lib/tls/libpthread.so.0 (0x40426000)
> > >         libc.so.6 => /lib/tls/libc.so.6 (0x42000000)
> > >         /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
> > >
> > > Thanks,
> > > Vijay Avarachen
> > >
> > >
> > > On Wed, 23 Mar 2005 10:13:04 +0530, Nitin Raina <nr at fluent.co.in>
wrote:
> > > > Hi Tim,
> > > >
> > > > Just install this openmotif RPM.
> > > >
> > > > openmotif21-2.1.30-6
> > > >
> > > > With this install qmon should work fine.
> > > >
> > > > Best,
> > > > Nitin
> > > >
> > > >
> > > > Tim Harsch wrote:
> > > > > Hi all,
> > > > >     I'm using RHEL4 with all updates applied via up2date, SGE6.0u3
via
> > > > > prebuilt binaries.  qmon seems to be expecting to find libXm.so.2.
My
> > > > > RedHat box appears to have a newer X11 than that expected by qmon.
So
> > my
> > > > > questions are:  does this mean that qmon was incorrectly linked
> > because it
> > > > > should be linked to libXm.so?  Also, how can I fix this?  I tried
to
> > link
> > > > > libXm.so.2 -> libXm.so.3 ( even though it seems like a hack ;-
which
> > it was
> > > > > see below ) ...
> > > > >
> > > > > Here's the error:
> > > > > $ qmon
> > > > > qmon: error while loading shared libraries: libXm.so.2: cannot
open
> > shared
> > > > > object file: No such file or directory
> > > > >
> > > > > And here's the libs:
> > > > > $ ls -la /usr/X11R6/lib/libXm.so*
> > > > > lrwxrwxrwx  1 root root      14 Mar  9 11:59
> > /usr/X11R6/lib/libXm.so ->
> > > > > libXm.so.3.0.2
> > > > > lrwxrwxrwx  1 root root      14 Mar  9 11:56
> > /usr/X11R6/lib/libXm.so.3 ->
> > > > > libXm.so.3.0.2
> > > > > -rwxr-xr-x  1 root root 2306740 Nov 29 06:20
> > /usr/X11R6/lib/libXm.so.3.0.2
> > > > >
> > > > > Here's the results of soft linking libXm.so.2 -> libXm.so.3
> > > > > $ qmon
> > > > > qmon: Symbol `_XmStrings' has different size in shared object,
> > consider
> > > > > re-linking
> > > > > Warning: XmtLoadResourceFile: file 'qmon_messages' not found.
> > > > > Warning: Cannot convert string "$interface" to type FontStruct
> > > > > Warning: Cannot convert string "intro" to type Pixmap
> > > > > X Error of failed request:  BadPixmap (invalid Pixmap parameter)
> > > > >   Major opcode of failed request:  55 (X_CreateGC)
> > > > >   Resource id in failed request:  0xc00018
> > > > >   Serial number of failed request:  204
> > > > >   Current serial number in output stream:  211
> > > > >
> > > > >
> > > > > Tim Harsch
> > > > > Computer Scientist
> > > > > Lawrence Livermore National Laboratory
> > > > > (925) 423-1135
> > > > >
> > > > >
> > > > >
> > > >
> ---------------------------------------------------------------------
> > > > > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > > > > For additional commands, e-mail:
users-help at gridengine.sunsource.net
> > > > >
> > > >
> > > > --
> > > > ---------------------------------
> > > >   Nitin Raina
> > > >   Team Leader - Computer Services
> > > >   Fluent India , Pune
> > > >   Tel: 91-20-56522500
> > > >   Fax: 91-20-56522600
> > > > ---------------------------------
> > > >
> > >
> ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > > > For additional commands, e-mail: users-help at gridengine.sunsource.net
> > > >
> > > >
> > >
> > >
> > > --
> > > "Knowledge is the only wealth that grows as you spend it, and
> > > diminishes as you save it."
> > > -- ancient Sanskrit saying
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > > For additional commands, e-mail: users-help at gridengine.sunsource.net
> > >
> > >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > For additional commands, e-mail: users-help at gridengine.sunsource.net
> >
> >
>
>
> -- 
> "Knowledge is the only wealth that grows as you spend it, and
> diminishes as you save it."
> -- ancient Sanskrit saying
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list