[GE users] qmon doesn't work on RHEL4

Tim Harsch harsch1 at llnl.gov
Thu Mar 24 21:06:45 GMT 2005


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Are you suggesting I downgrade?  I have:
$ rpm -qa | grep motif
openmotif21-2.1.30-11.RHEL4.2
openmotif-2.2.3-6.RHEL4.2
openmotif-devel-2.2.3-6.RHEL4.2


----- Original Message ----- 
From: "Nitin Raina" <nr at fluent.co.in>
To: <users at gridengine.sunsource.net>
Sent: Tuesday, March 22, 2005 8:43 PM
Subject: Re: [GE users] qmon doesn't work on RHEL4


> Hi Tim,
>
> Just install this openmotif RPM.
>
> openmotif21-2.1.30-6
>
> With this install qmon should work fine.
>
> Best,
> Nitin
>
>
>
> Tim Harsch wrote:
> > Hi all,
> >     I'm using RHEL4 with all updates applied via up2date, SGE6.0u3 via
> > prebuilt binaries.  qmon seems to be expecting to find libXm.so.2.  My
> > RedHat box appears to have a newer X11 than that expected by qmon.  So
my
> > questions are:  does this mean that qmon was incorrectly linked because
it
> > should be linked to libXm.so?  Also, how can I fix this?  I tried to
link
> > libXm.so.2 -> libXm.so.3 ( even though it seems like a hack ;- which it
was
> > see below ) ...
> >
> > Here's the error:
> > $ qmon
> > qmon: error while loading shared libraries: libXm.so.2: cannot open
shared
> > object file: No such file or directory
> >
> > And here's the libs:
> > $ ls -la /usr/X11R6/lib/libXm.so*
> > lrwxrwxrwx  1 root root      14 Mar  9 11:59 /usr/X11R6/lib/libXm.so ->
> > libXm.so.3.0.2
> > lrwxrwxrwx  1 root root      14 Mar  9 11:56
/usr/X11R6/lib/libXm.so.3 ->
> > libXm.so.3.0.2
> > -rwxr-xr-x  1 root root 2306740 Nov 29 06:20
/usr/X11R6/lib/libXm.so.3.0.2
> >
> > Here's the results of soft linking libXm.so.2 -> libXm.so.3
> > $ qmon
> > qmon: Symbol `_XmStrings' has different size in shared object, consider
> > re-linking
> > Warning: XmtLoadResourceFile: file 'qmon_messages' not found.
> > Warning: Cannot convert string "$interface" to type FontStruct
> > Warning: Cannot convert string "intro" to type Pixmap
> > X Error of failed request:  BadPixmap (invalid Pixmap parameter)
> >   Major opcode of failed request:  55 (X_CreateGC)
> >   Resource id in failed request:  0xc00018
> >   Serial number of failed request:  204
> >   Current serial number in output stream:  211
> >
> >
> > Tim Harsch
> > Computer Scientist
> > Lawrence Livermore National Laboratory
> > (925) 423-1135
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > For additional commands, e-mail: users-help at gridengine.sunsource.net
> >
>
> -- 
> ---------------------------------
>   Nitin Raina
>   Team Leader - Computer Services
>   Fluent India , Pune
>   Tel: 91-20-56522500
>   Fax: 91-20-56522600
> ---------------------------------
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list