[GE users] high CPU load for sge_qmaster

christian reissmann Christian.Reissmann at Sun.COM
Mon May 9 16:52:30 BST 2005


Hi Sean, Stephan

FYI: Your using 60u3 in CSP mode, the CSP framework was reworked for the
60u4 release. May it be an option for you to switch to 60u4?

Shutting down the qmaster in CSP mode for 60u3 requires resyncronizing
between master and exec daemons. This results in several error messages
and can take (in the worst case) up to 7 minutes. As you see from the log
the execds reconnected within one minute ;-)

This is a protocol inherent problem for 60u3 and below.

Did all execd reconnect again? Was the master still busy for a longer time
afterwards?


Best Regards,

Christian

Sean Dilda wrote:
> 
> 
> Thanks for the reminder.  I restarted my sge_qmaster on the 3rd, and my 
> load monitoring showed the load shooting up around 6pm that evening. 
> There was some interesting stuff in the logs that I meant to send, but 
> kept forgetting to.  I should note that I am using CSP.  Here are the logs:
> 
-- 
Christian Reissmann    Tel: +49 (0)941 3075 112  mailto:crei at sun.com
Software Engineer      Fax: +49 (0)941 3075 222  http://www.sun.com/gridengine
Sun Microsystems GmbH, Dr.-Leo-Ritter-Str. 7,
D-93049 Regensburg,    Tel: +49 (0)941 3075 0


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list