[GE users] Urgent help qsub

Chris Dagdigian dag at sonsorol.org
Sat Nov 26 14:35:19 GMT 2005


Looks OK to me, 90% of your command is blast and its options ...


What happens when you try this command outside of Grid Engine?

  $ /blast/bin/blastall -i /tmp/some.fasta -o /tmp/some.xml -p blastp  
-m 7


What happens when you try the command via qrsh?


qrsh  /blast/bin/blastall -i /tmp/some.fasta -o /tmp/some.xml -p  
blastp -m 7


And finally, when the job is stuck with status "Eqw" what does the  
output of "qstat -j <jobID>" tell you about that job?


Oh wait ...


I think I do see a problem with your blast command -- you are not  
picking a database target?

Blast works like:

  blastall -p <program> -i <input queries> -d <database>  <other  
blast options>

And it looks like you are not passing in a "-d <database> argument"  
--- that will cause your command to not work, it may even cause

-Chris



On Nov 24, 2005, at 6:51 PM, Mr. Syed Aijaz wrote:

> Hi all,
>
> Can anyone let me know if there is anything wrong in the following
> qsub commond line? I am able to succesfully submit the job, but
> the job does not run, it is always stuck with status 'Eqw'. Thanks.
>
> qsub -b y -e /tmp/ -o /tmp/ /blast/bin/blastall -i /tmp/some.fasta -o
> /tmp/some.xml -p blastp -m 7
>
> cheers,
> Aijaz.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list