[GE users] SGE 6.0u7 Installation error

Richard Ems r.ems at gmx.net
Wed Apr 26 22:57:11 BST 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Chris Dagdigian wrote:
> 
> On Apr 26, 2006, at 5:20 PM, Richard Ems wrote:
>>
>> Can this also be "corrected" in host_aliases? How? Does SGE a kind of
>> "sort -n" of the IP-Addresses or were does it get the order from in
>> "Host Address(es)"?
> 
> 
> When Grid Engine daemons first start up, it seems that one of their
> first actions involves reading $SGE_ROOT/$SGE_CELL/common/act_qmaster to
> learn the hostname of the acting qmaster node. That is the hostname they
> use when trying to make TCP connections.
> 
> My experience has been that as long as you know what is in
> 'act_qmaster', you usually only have to make a single entry in
> host_aliases to 'train' SGE which network route or IP address to use.

But "lsof -i :my_sge_ports" shows that sge_master and sge_schedd bind on
all interfaces, not just on one IP-address.

The entry in host_aliases should then be

hostname    ip_address_needed_for_SGE    (how is this ip-address
defined, which is it when the master node has several NICs? What if I
have execution nodes that are reached over different NICs ? What does
SGE need this "first" ip-address for?)

???


Many thanks, Richard

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list