[GE users] Getting mvapich tight integration working

Andreas.Haas at Sun.COM Andreas.Haas at Sun.COM
Wed Aug 2 15:59:54 BST 2006


On Wed, 2 Aug 2006, Daryl Herzmann wrote:

> Hi!
>
> On Wed, 2 Aug 2006, Andreas.Haas at Sun.COM wrote:
>
>> I haven't followed the thread, but the "rcmd: socket: Permission denied" 
>> usually is due to a lack of priviledges of Grid Engine rsh/rlogin/rlogin in 
>> utilbin directory.
>
> Thanks!
>
> [akrherz at compute-0-1 lx26-amd64]$ ls -l rsh rshd rlogin
> -rwxr-xr-x  1 sge sge  25384 Oct 18  2005 rlogin
> -rwxr-xr-x  1 sge sge  16153 Oct 18  2005 rsh
> -rwxr-xr-x  1 sge sge 210141 Oct 18  2005 rshd
>
> that's not good :(  I wonder how they got like that!
>
> So I changed them to
>
> [akrherz at compute-0-0 lx26-amd64]$ ls -l rlogin rsh rshd
> -r-S--s--x  1 root root  25384 Oct 18  2005 rlogin
> -r-S--s--x  1 root root  16153 Oct 18  2005 rsh
> -rwxr-xr-x  1 sge  sge  210141 Oct 18  2005 rshd

Hm. Somehow in my installation they look different

-r-s--x--x   1 root     root       32607 Apr 12 16:25 rlogin
-r-s--x--x   1 root     root       21944 Apr 12 16:25 rsh
-rwxr-xr-x   1 root     root      215212 Apr 12 16:25 rshd

note there is $SGE_ROOT/util/setfileperm.sh for setting
fileperms correctly.

>
> So I try my script again and get
>
> poll: protocol failure in circuit setup
> poll: protocol failure in circuit setup
> poll: protocol failure in circuit setup
> poll: protocol failure in circuit setup

>
> Any ideas?  Sorry I am such a newbie :(

Try the above.

Regards,
Andreas

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list