[GE users] Re: Error compiling SGE from source

Nathan Harmston ratchetgrid at googlemail.com
Wed Aug 9 11:11:59 BST 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi,

I m trying to compile SGE 6 with usermapping enabled however I cant get it
to compile. Im compiling on Linux and have build sge_depend and created the
dependencies however I get an error when I try to compile using:

./aimk -spool-classic -sunman -umap -kerberos

Is usermapping enabled in 6 yet --> I found some emails from last year
discussing this. Is this error to do with this? Many Thanks

Nathan

-bash-3.00$ ./aimk -spool-classic -sunman -umap -kerberos
making in LINUX86_26/ for LINUX86 at host grid.mycib.ac.uk
_________C_O_R_E__S_Y_S_T_E_M_____________
gcc -O3 -Wall -Werror -Wstrict-prototypes -D__GRIDENGINE_FD_SETSIZE=8192
-DLINUX -DLINUX86 -DLINUX86_26 -D_GNU_SOURCE -DGETHOSTBYNAME_R6
-DGETHOSTBYADDR_R8  -DHAS_IN_PORT_T -DLOAD_OPENSSL -DLOAD_OPENSSL -DKERBEROS
-I../security/krb -I/vol2/tools/SW/krb5/lx26-x86/include
-I/vol2/tools/SW/krb5/lx26-x86/include/gssapi
-I/vol2/SW/db-4.4.20/lx26-x86/include/
-DTARGET_32BIT  -DSPOOLING_classic -DSECURE
-I/vol2/tools/SW/openssl-0.9.7e/lx26-x86/include
-DCOMPILE_DC -D__SGE_COMPILE_WITH_GETTEXT__  -I../common -I../libs
-I../libs/uti -I../libs/gdi -I../libs/japi -I../libs/sgeobj -I../libs/cull
-I../libs/rmon -I../libs/comm -I../libs/comm/lists -I../libs/sched
-I../libs/evc -I../libs/evm -I../libs/mir -I../libs/lck -I../daemons/common
-I../daemons/qmaster -I../daemons/execd -I../daemons/schedd
-I../clients/common -I. -I/usr/java/jdk1.5.0_05/include
-I/usr/java/jdk1.5.0_05/include/linux -fPIC -c ../libs/sgeobj/sge_cuser.c
cc1: warnings being treated as errors
../libs/sgeobj/sge_cuser.c: In function 'cuser_list_get_master_list':
../libs/sgeobj/sge_cuser.c:172: warning: implicit declaration of function
'object_type_get_master_list_mt'
../libs/sgeobj/sge_cuser.c:172: error: 'SGE_TYPE_CUSER' undeclared (first
use in this function)
../libs/sgeobj/sge_cuser.c:172: error: (Each undeclared identifier is
reported only once
../libs/sgeobj/sge_cuser.c:172: error: for each function it appears in.)
../libs/sgeobj/sge_cuser.c:172: warning: return makes pointer from integer
without a cast



More information about the gridengine-users mailing list