[GE users] about submit serial and parallel job

Reuti reuti at staff.uni-marburg.de
Fri Aug 11 23:09:55 BST 2006


Hi,

Am 11.08.2006 um 09:44 schrieb mashaojie163:

> Dear Sir:
>             Thank you for your patience. I  have understood what  
> you mean. Howerver , there is still a problem.
>              According to what you mean,.
>
>              The complex definition has to be read this way:
>              "your request"   "defined relation"  "reported value"
>
>               I modified the relation of variable "load_avg" as  
> "<=" . I excute the command:
>               qhost -l load_avg=0.8 -F load_avg.
>
>              It display the hosts have been occupied (including  
> full hosts and not full hosts.).  That is right.
>
>              I submit   a serial job as following:
>              qsub -hard -l load_avg  -pe mpich 1 myscript
>
>              I find the job was always submitted to the hosts which  
> are occupied and not full. That is also right.
>
>              However, when I submit a serial job softly as following:
>              qsub -soft -l load_avg  -pe mpich 1 myscript
>
>             I  find the jobs was always submitted to the hosts  
> which are empty absolutely, although there are some hosts which are  
> not full. I am confused.

for me this seems working - I only notice a delay of load_avg (AFAIK  
it's the 5 minues load as in uptime). Can you please try the same  
with load_short, whether there is a difference?

-- Reuti

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list