[GE users] posix priority ignored?

Chris Dagdigian dag at sonsorol.org
Mon Aug 28 12:15:48 BST 2006


I think ...

For POSIX priority, only SGE managers can use priority values greater  
than zero  (0-1024) , "regular" users can use values less than zero  
(-1024 to 0)

--Chris


On Aug 28, 2006, at 6:29 AM, Karl Friedrich Walkow wrote:

> Dear All,
>
> we run a small cluster that is used by a very small group of  
> (power-)users.
>
> The sge installation (version 6.0u8) works really fine, but we  
> still have a problem with the job ordering. For us the most simple,  
> obvious solution might be to use posix priorities to determine the  
> order of jobs in the queue.
>
> The problem now is, that qsub seems to ignore the specified value  
> from the -p option. If I call
>
> qsub -p 100 simple_job.sh
> qsub -p 200 simple_job.sh
> qsub -p 50 simple_job.sh
>
> the job are sorted in FIFO-order and
>
> qstat -pri
>
> shows just 0 in the ppri column.
>
> Did I understand something wrong on the usage of the -p option?
>
> Do I have to change something in the sge configuration (As far as I  
> understood from the docs, this should not be the case...) ?
>
>
> Much thanks for advice an best regards,
>
> Karl F. Walkow
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list