[GE users] Question About Complex Resources

Langston, Chris Chris.Langston at aa.com
Mon Aug 28 18:12:54 BST 2006


Sorry. My mistake. I was putting the qsub command in a case statement
and populating the resource requirements in as a variable and
accidentally misspelled the variable. When I fixed the variable, it
worked.

-----Original Message-----
From: Reuti [mailto:reuti at staff.uni-marburg.de] 
Sent: Monday, August 28, 2006 11:46 AM
To: users at gridengine.sunsource.net
Subject: Re: [GE users] Question About Complex Resources

Hi,

Am 28.08.2006 um 18:13 schrieb Langston, Chris:

> I'm puzzled about the behavior of SGE (6.0u7) with regard to  
> complex resources. What should happen if a job request a non- 
> existant resource? I would think it should keep the job in the  
> queue if I'm using the -now n switch. What I'm experiencing is that  
> the job is still getting dispensed to the first available queue. Is  
> this correct behavior?
I get this:

$ qsub -l unknown=4 -now n test.sh
Unable to run job: unknown resource "unknown".
Exiting.

What was the unknown resource in detail in your case?

-- Reuti
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list