[GE users] Anybody able to get SGE MPICH2 Tight Integration via SSH working? - SOLVED

Jonathan Schreiter jonathanschreiter at yahoo.com
Thu Jan 5 20:01:39 GMT 2006


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Thanks everyone for your help on resolving this issue.
 I'll post what I did for anyone else who is trying to
get this working (and for me when I forget what I
did).  

1) Follow ssh howto and ssh tight integration howto
(with minor changes below)

2) Changes to Reuti's start_mpich2.c
rsh_argv[0]="rsh"; to rsh_argv[0]="ssh";
rsh_argv[3]="-port"; to rsh_argv[3]="-p";

then rerun ./aimk and ./install.sh

This changes the way
$SGE_ROOT/mpich2_smpd/bin/$ARCH/mpich2 calls qrsh to
start smpd on the exe hosts from rsh to ssh.

3) Turned off the firewall on master host (not sure if
this is required - i'll try tweaking this install
later)

4) Verified that sgeadmin (my sge install/runas
account) and myusseraccount  had proper
authorized_keys (one per line) for each exe host and
master host.  I used ssh-keygen -d w/o a passpharase.

5) Had to make sure in the Queue configuration -
General Configuration - Shell was set to /bin/sh
(solved a tty error)

6) Don't forget to make sure the parallel environment
allocation_rule is set to $round_robin, instead of the
default.  Reuti's doc shows that, but I missed that. 
This is important so that the correct list is
generated for the machines file.

7) I modified the sample script to this and ran it:
port=$((JOB_ID % 5000 + 20000))

echo "Got $NSLOTS slots."

/usr/local/bin/n1ge6/mpich2_smpd/bin/mpiexec -n
$NSLOTS -machinefile $MPIR_HOME/machines -p $port
$MPIR_HOME/examples/cpi

I'm sure I'll have many more questions down the
line...but for now...

Thanks again everyone!
Jonathan

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list