[GE users] mixed afs environment and pag_cmd

Reuti reuti at staff.uni-marburg.de
Tue Jan 17 17:05:12 GMT 2006


Hi,

Am 17.01.2006 um 16:48 schrieb Kirk Patton:

> Hello all,
>
> I am making progress getting my SGE/AFS test cluster set up, but my  
> real environment is mixed.
> We have some AFS machines, and some that do not do AFS.
>
> I was considering setting my 'pag_cmd' to a script that can test  
> the target system for the
> presence of the /afs directory.  If it is there, then the job would  
> authenticated the user
> using afs.  If it was not there, then the job would skip afs  
> authentication.
>
> I was thinking of a script allong the lines of
>
> #!/bin/bash
>
> if [ -d /afs ]; then
>   exec /usr/afswf/bin/pagsh -c $*
> else
>   exec /bin/sh -c $*
> fi
>
>> From a xterm, this script does what I expect, but when run as the  
>> pag_cmd, I get an
> error, "Your "qrsh" request could not be scheduled, try again later."
>

I'm not used to AFS, but from the man page to sge_conf, this can be  
set for each host locally. So maybe leave this option to the default  
in the SGE configuration, and define it only for the machines with  
AFS in their local conf. - Reuti

> Does anyone have an suggestions on how to set up the pag_cmd?
>
> Thanks,
> Kirk
>
>
>
>
> -- 
> Kirk Patton
> Unix Administrator
> Transmeta Inc.
> Tel. 408 919-3055
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list