[GE users] Clearing errors: qmod -cq / qmod -cj issues

Sebastian Stark stark at tuebingen.mpg.de
Tue Jan 24 11:26:09 GMT 2006


neckar ~ % qstat -f | awk '$6 ~ /E/ {print $1}'
all.q at node120
all.q at node132
all.q at node135
all.q at node138
neckar ~ % qmod -cq all.q at node120 all.q at node132 all.q at node135  
all.q at node138
invalid queue "all.q at node120"
invalid queue "all.q at node132"
invalid queue "all.q at node135"
invalid queue "all.q at node138"

What am I doing wrong?

The help page seems confused about this:

neckar ~ % qmod -help | grep error
    [-c job_wc_queue_list]  clear error state
    [-cj wc_queue_list]     clear job error state
    [-cq job_list]          clear queue error state

Looks as if those two options cj and cq are swapped. But it still  
does not work if I swap them again:

neckar ~ % qmod -cj all.q at node120 all.q at node132 all.q at node135  
all.q at node138
invalid queue or job "all.q at node120"
invalid queue or job "all.q at node132"
invalid queue or job "all.q at node135"
invalid queue or job "all.q at node138"

Legacy mode does not work as well:

neckar ~ % qmod -c all.q at node120 all.q at node132 all.q at node135  
all.q at node138
invalid queue "all.q at node120"
invalid queue "all.q at node132"
invalid queue "all.q at node135"
invalid queue "all.q at node138"


So, how do I clear the error state?



-Sebastian


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list