[GE users] keep getting: Jobs can not run because the resource requirements can

John G Layne/laynejg/O/VCU laynejg at vcu.edu
Wed Jan 25 19:02:16 GMT 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

hye folks,
    I don't know if the original poster has solved his/her problem; I was
experiencing something similar.  I had a PE I called mpich-all, but some of my
nodes were down so I edited the Queues list to exclude those nodes, and then
upon trying to submit parallel jobs I recieved messages like:

qsub -w v -pe mpich-all 3 mpihello_script.sh
Your job cannot run in queue "node21.q" because it is not in queue
list of PE "mpich-all"
Your job cannot run in queue "node30.q" because it is not in queue
list of PE "mpich-all"
Your job cannot run in queue "node31.q" because it is not in queue
list of PE "mpich-all"
Your job cannot run in queue "node32.q" because it is not in queue
list of PE "mpich-all"
Your job cannot run in queue "node29.q" because it is not in queue
list of PE "mpich-all"
Your job cannot run because resources requested are not available for
parallel job
verification: no suitable queues

    I finally compared my qmon settings on this cluster to those on another I
had working & noticed the difference in Allocation Rule between the working &
non-working PEs.  I had $pe_slots on the non-working PE, which of course was not
what I wanted at all; I switched this to $fill_up which does what I want on the
other cluster & everything is working like a charm now.  Hope that helps
somebody!
    johnny
--------------------------------------------------------------------- To
unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net For additional
commands, e-mail: users-help at gridengine.sunsource.net



More information about the gridengine-users mailing list