[GE users] smp environment trouble

k.radacki k.radacki at mail.uni-wuerzburg.de
Sun Jun 4 14:00:40 BST 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Reuti wrote:

> Hi,
>
> Am 04.06.2006 um 14:40 schrieb k.radacki:
>
>> Dear All,
>> I'm trying to set SGE6 to run parallel SMP jobs on the same dual  
>> processor node.
>> All hosts are dual machines and are have two slots in queue.
>>
>> I've created with qconf -am smp a following file:
>> pe_name           smp
>> slots             2
>> user_lists        NONE
>> xuser_lists       NONE
>> start_proc_args   /bin/true
>> stop_proc_args    /bin/true
>> allocation_rule   $fill_up
>> control_slaves    FALSE
>> job_is_first_task FALSE
>> urgency_slots     min
>>
>> I've tried both $fill_up and $pe_slots but in both cases when I  
>> submit with
>> -pe smp 2 the job stuck as pending
>> 29 0.60500 g03-test    testuser      qw    06/04/2006 15:22:14     2
>>
>> Btw, when I tried standard parallel environment make with -pe make 2
>> the job was allocated on two nodes each with one slot used (however
>> as program is "smp" one, it  started both treads on one node and  the 
>> other
>> one had load=0.0)
>>
>> Can somebody point me out where I'm making an error?
>
>
> qalter -w v 29
>
> will check the available queues.
>
> You attached this PE also to a queue of your coice (using $pe_slots)?  

Nope... How should I do it?

> BTW: slots in the PE definition are the slots used in total for this  
> PE at the same time. Often it's advisable to set it to two times the  
> number of hosts for dual machines.
>
> -- Reuti 

thanks
kris

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list