[GE users] How to delete mpi batch processes after qdel

Personal Técnico DACSO tecnicos at aomail.uab.es
Wed Jun 28 17:16:12 BST 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hello everybody!

We have a problem in queue management with SGE. If we run "qdel ID_JOB" 
when the job has entered in execution, SGE removes the job from the 
queue instance, but the process remains running in the nodes. After 
reading a lot of articles, we think the only solution is modifying the 
"stopmpi.sh" script in order to obtaing de PIDs of all the processes and 
kill them. Does anybody know a better way to do this?

In addition, we have another problem similar to this. In our system we 
have 2 queues subordinated to a global queue. That is, when a user 
submits a job to the global queue, the jobs in the other 2 queues become 
Suspended. The problem is that the suspended jobs remain running in the 
nodes (that is, they are only Suspended in the SGE Queue Management), so 
they use memory and cpu, and modify the results of the other jobs. Any 
solution for this problem?

Thanks in advance!

-- CTS (CAOS Technical Staff) --
University Autonoma of Barcelona


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list