[GE users] qmaster logging error every 10 seconds

Sean Dilda sean at duke.edu
Fri Jun 30 14:44:56 BST 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Greg A wrote:
> We are receiving the following error every 10 seconds in the messages 
> file on the qmaster.  I've tryed a snoop and truss to try and capture 
> what/who is causing the message but I'm coming up empty.  I also tried 
> changing the loglevel to equal log_info but that didn't shed anymore light.
> 
> 06/29/2006 17:53:32|qmaster|masterhost|E|denied: "remote" must be 
> manager for this operation
> 06/29/2006 17:53:42|qmaster|masterhost|E|denied: "remote" must be 
> manager for this operation
> 06/29/2006 17:53:52|qmaster|masterhost|E|denied: "remote" must be 
> manager for this operation
> 
> The scheduler runs every 10 seconds but a truss of the scheduler doesn't 
> have any information.  There are no jobs in error state and nobody with 
> a user account of remote trying to qsub jobs.

The 10 second thing is suspicious.  If you think it's related to the 
scheduler, you can try killing sge_schedd and seeing if the messages go 
away.  You can then later run the sge_schedd binary and it will start up 
normally.

Out of curiosity, what userid is 'sge_schedd' running as?  Is it running 
as user 'remote'?

> 
> Does anyone have any ideas on how I can find the node/job/process 
> causing this error?

You can try running netstat on the qmaster host to see what's 
connecting.  However, if you have a lot of compute nodes, there may be a 
lot of connections.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list