[GE users] qacct exit status

Rayson Ho rayrayson at gmail.com
Tue Mar 7 13:42:06 GMT 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Do you have "exit 0" at the end of the job script?? Further, do you
have an explict "exit <value>" statement in the script??

Rayson



On 3/7/06, laikwong <laikwong at comp.nus.edu.sg> wrote:
> I am using qacct -j <job_id> to get the exit status of my jobs.
>
> However, the exit_status I receive is often non-zero, but as far as I am
> concerned, the job I submitted has executed "correctly".
> .....
> .....
> granted_pe   NONE
> slots        1
> failed       0
> exit_status  80
> .....
> ....
>
> Is there a resource where I can lookup to determine the meanings of the exit
> codes? Or is there a reason why my jobs might have a non-zero exit status
> despite the fact that I think they exectued "correctly".
>
> What I really need is a clear indication from "somewhere" in SGE that either
> the job has completed successfully or has failed. I am basically only
> interested in these 2 outcomes SUCCESS | FAILURE, how it fails I am not so
> concerned at this point in time (possibly in the near future I might be
> interested to know).
>
> Thanks
>
> Daniel

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list