[GE users] How to clear internal hostname cache?

Kim Leng Goh kimleng.goh at gmail.com
Tue Mar 21 09:46:20 GMT 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi Christian,
  Thanks for the speedy reply.

On 3/21/06, christian reissmann <Christian.Reissmann at sun.com> wrote:
[...]
>
> The cl_commlib.c module was developed for 6.0! The 5.3p6 version uses
> sge_commd to resolve hostnames and has no cache at all.
> So I don't understand the question.
[...]

My problem is that SGE seems to think that my compute-0-7 node has the
hostname "network-0-0.local" when in fact it isn't (which prompted me
to think that this was in some cache somewhere or stored somewhere
else):

[root at compute-0-7 root]# qstat -f
denied: host "network-0-0.local" is neither submit nor admin host


Reinstalling sge on the compute node or reinstalling the compute node
doesn't seem to help:


[root at compute-0-7 gridengine]# ./install_execd -auto

Confirm Grid Engine default installation settings
-------------------------------------------------

The following default settings can be used for an accelerated
installation procedure:

      $SGE_ROOT          = /opt/gridengine
      service            = sge_commd
      admin user account = sge

Do you want to use these configuration parameters (y/n) [y] >>
denied: host "network-0-0.local" is neither submit nor admin host



Checking hostname resolving
---------------------------
denied: host "network-0-0.local" is neither submit nor admin host

denied: host "network-0-0.local" is neither submit nor admin host


This host has the local hostname >compute-0-7.local<.

This host is unknown on the qmaster host.

Please make sure that you added this host as administrative host!
If you did not, please add this host now with the command

   # qconf -ah HOSTNAME

on your qmaster host.

Check again (y/n) [y] >>

Checking hostname resolving
---------------------------
denied: host "network-0-0.local" is neither submit nor admin host

denied: host "network-0-0.local" is neither submit nor admin host


This host has the local hostname >compute-0-7.local<.

This host is unknown on the qmaster host.

Please make sure that you added this host as administrative host!
If you did not, please add this host now with the command

   # qconf -ah HOSTNAME

on your qmaster host.

If this host is already added as administrative host on your qmaster host
there may be a hostname resolving problem on this machine.

Please check your >/etc/hosts< file and >/etc/nsswitch.conf< file.

Hostname resolving problems will cause the problem that the
execution host will not be accepted by qmaster. Qmaster will
receive no load report values and show a load value
(>load_avg<) of 99.99 for this host.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list