[GE users] etherogenous cluster and qrsh not working

davide cittaro daweonline at gmail.com
Wed Mar 29 13:55:48 BST 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi all, I have installed sge 6 on 5 machines all runnning linux:

$ qconf -sep
HOST                      PROCESSOR        ARCH
===============================================
alpha1.bioinfo.ifom-ieo-          2  lx24-alpha
alpha2.bioinfo.ifom-ieo-          2  lx24-alpha
ia32.bioinfo.ifom-ieo-ca          2    lx26-x86
itanium1.bioinfo.ifom-ie          4   lx26-ia64
itanium2.bioinfo.ifom-ie          4   lx26-ia64
===============================================
SUM                              14

Although simple tasks can be submitted via qsub, it seems that I
cannot run qrsh and qmake.
First of all when I try

$ qrsh -verbose hostname

no matters which host I run from, everything is sent alway to the same host.
Also, even if I set the $SGE_ARCH value, I cannot use qmake:

$ qmake -v PATH -cwd -pe make 4 --
Your "qrsh" request could not be scheduled, try again later.

The only thing I can do is setting a variable number of slots:

$ qmake -v PATH -cwd -pe make 2-14 --

But then the parallel make is made only on machines that have the same
ARCH value.
Everything seems to work _only_ if I launch from ia64 machines...
Since I'm not compiling anything and the qmake is made only to run a
software n times in parallel, I would like to know how can I make
this, how can I run qmake on different architectures...

Thanks

d
--
dawe
http://dawe.ilbello.com
---
"Prediction is very difficult, especially if it's about the future." -
Niels Bohr

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list