[GE users] N1GE - LDAP

Rui Ramos rramos at iric.up.pt
Wed May 17 13:03:22 BST 2006


 Ok, it's done. 

If somebody else has the same problem. just configure the LDAP and check with "getent passwd"
 After that restart the "sge_execd" in all nodes (i've missed this part.) It seems the sge_execd load the users from the LDAP server when boots. I guess each time a user is added to the server the daemons must be restarted also. (not certain) 

                                       Cheers

On Tue, 16 May 2006 09:01:01 +0100
Rui Ramos <rramos at iric.up.pt> wrote:

> 
>  Hi Andre,
> 
>  I didn't quite follow that manual. But i have the ldap working as a can ssh with an ldap user in both of the machines.
> 
> By the way my nsswitch.conf 
> 
> passwd:     files ldap
> shadow:     files ldap
> group:      files ldap
> 
> Maybe it's something related with pam. I didn't find out yet. Any other clues ?
> 
>                                               Best regards
> 
> On Tue, 16 May 2006 09:02:26 +0200
> Andre Alefeld <Andre.Alefeld at Sun.COM> wrote:
> 
> > Hi,
> > 
> > did you follow all the steps outlined here
> > http://www.redhat.com/docs/manuals/linux/RHL-7.1-Manual/ref-guide/s1-ldap-redhattips.html   
> > ?
> > Especially the correct settings in /etc/nsswitch.conf and pam 
> > configuration are important.
> > Your master machine has to support this of course as well.
> > 
> > Andre
> > 
> > Rui Ramos wrote:
> > >  Hi,
> > >
> > >   Thanks on the quich reply.
> > >
> > > On Mon, 15 May 2006 09:02:00 -0700
> > > Brady Catherman <bradyc at uidaho.edu> wrote:
> > >
> > >   
> > >> I am running LDAP through Mac OS and it works great. What OS are you  
> > >> using and how did you go about configuring LDAP?
> > >>
> > >>     
> > >
> > >  I'm using RedHat ES 4
> > >
> > >  Did you have to configure anything in the gridengine ? i only set this a testuser that is in the LDAP server and the submission goes well. But it seems that when gets to the sge_master on other node it doesn't get the passwd.
> > >
> > > I've taken out the TLS and it doesn't work also. I don't bealive it's a ldap problem because i can chown to the users. Any clue ?
> > >
> > >   
> > >> On May 15, 2006, at 8:54 AM, Rui Ramos wrote:
> > >>
> > >>     
> > >>>  Hi there,
> > >>>
> > >>>   Does anybody have the GridEngine working with LDAP. I have a  
> > >>> external LDAP server where i get the user and group ID's but when  
> > >>> submitting a job i get:
> > >>>
> > >>> " can't get password entry for user "rramos". Either the user does  
> > >>> not exist or NIS error! "
> > >>>
> > >>> I can connect to all the nodes with this user. If i set the user in  
> > >>> passwd it work's. But i don't want to do that.
> > >>>
> > >>> when submitting i see it gets the Id's correctly
> > >>>
> > >>> owner:                      userX
> > >>> uid:                        10001
> > >>> group:                      groupX
> > >>> gid:                        10000
> > >>>
> > >>> but when i do qacct -j jobID i get:
> > >>>
> > >>> group        UNKNOWN
> > >>> owner        userX
> > >>>
> > >>> I'm using SGE6_u7.
> > >>>
> > >>>                                     Any thoughts ? thanks in advance
> > >>>
> > >>> -- 
> > >>> ============================================
> > >>>  Rui Manuel dos Santos Ramos
> > >>>
> > >>>  Instituto de Recursos e Iniciativas Comuns
> > >>>  Pra_a Gomes Teixeira, 4099-002 Porto, Portugal
> > >>>
> > >>>  phone : +351 223 401 571
> > >>>  e-mail: rramos[at]iric.up.pt
> > >>> ============================================
> > >>>
> > >>>       
> > >> ---------------------------------------------------------------------
> > >> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > >> For additional commands, e-mail: users-help at gridengine.sunsource.net
> > >>     
> > >
> > >
> > >   
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > For additional commands, e-mail: users-help at gridengine.sunsource.net
> 
> 
> -- 
> ============================================
>  Rui Manuel dos Santos Ramos
> 
>  Instituto de Recursos e Iniciativas Comuns
>  Pra_a Gomes Teixeira, 4099-002 Porto, Portugal
> 
>  phone : +351 223 401 571
>  e-mail: rramos[at]iric.up.pt
>     web: http://ruiramos.no-ip.com
> ============================================
> 
> 


-- 
============================================
 Rui Manuel dos Santos Ramos

 Instituto de Recursos e Iniciativas Comuns
 Pra_a Gomes Teixeira, 4099-002 Porto, Portugal

 phone : +351 223 401 571
 e-mail: rramos[at]iric.up.pt
    web: http://ruiramos.no-ip.com
============================================



    [ Part 2, Application/PGP-SIGNATURE 494 bytes. ]
    [ Unable to print this part. ]



More information about the gridengine-users mailing list