[GE users] Newbie: @group and fractional usage

David Kulp dkulp+sge at cs.umass.edu
Wed May 17 15:08:59 BST 2006


On May 17, 2006, at 9:35 AM, Sean Dilda wrote:

> David Kulp wrote:
>> I have two questions as a new grid engine user.
>> First, I'm running on linux and attempts to create a userlist  
>> with  the @unixgroup notation doesn't seem to work.  qmon accepts  
>> it, but  subsequent commands don't recognize it.  For example, I  
>> added  "@group" to the deadlineusers userset, but when I try to  
>> submit  deadline jobs I get an error 'job rejected: the user  
>> "dkulp" is no  deadline initiation user'.  Deadline job submission  
>> only works when I  add my explicit username in the deadlineusers  
>> userset.  But I don't  want to do that for every new user.
>
> When you run 'qconf -sconf', look under execd_params.  Is  
> 'USE_QSUB_GID' set?   If its not set, SGE looks at whatever group  
> is defined for your using in /etc/passwd (or nis or ldap, or  
> whatever you're using).  If the option is set to true, then SGE  
> looks at your active group when you run qsub to determine your  
> group.   SGE never looks at any of the other groups you might be in.

Hmm.  I'm use /etc/passwd.  There are no execd_params parameters  
set.  And yet the group name (from /etc/group) specified for the user  
in /etc/passwd does not work.  I've tried "@group", "group", "@gid",  
and "gid".  I also tried adding "USE_QSUB_GID" to execd_params.  I  
checked my current gid with "id -g" and updated the userlist  
accordingly.  But still no go.  Only individual user names works for me.

-d

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list