[GE users] OpenMPI 1.2 integration and dedicated MPI networks

Orion Poplawski orion at cora.nwra.com
Fri Oct 20 00:08:30 BST 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

I'm starting to test out OpenMPI 1.2 tight integration with SGE and have 
run into the following issue.  Currently, my startmpi script massages 
the hostnames in the machines file created from the SGE pe_hostfile add 
an "x" suffix on machines that are connected with a separate GigE 
network dedicated for MPI traffic.

With tight integration, openmpi uses the SGE pe_hostfile directly, e.g.:

coop00.cora.nwra.com 2 coop.q at coop00.cora.nwra.com <NULL>
coop01.cora.nwra.com 2 coop.q at coop01.cora.nwra.com <NULL>

Now, how/can I modify this so that MPI traffic speaks to coop00x and 
coop01x?  One immediate problem that I'm running into is that the 
startmpi script from the SGE PE runs as the user of the job so it can't 
modify pe_hostfile.


-- 
Orion Poplawski
System Administrator                  303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  orion at cora.nwra.com
Boulder, CO 80301              http://www.cora.nwra.com

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list