[GE users] Master host install problem

wzlu wzlu at gate.sinica.edu.tw
Mon Oct 23 09:41:40 BST 2006


    [ The following text is in the "Big5" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Dear All,

I am trying to install Grid Engine for testing.
To install the master host, I meet a error message as following:

------------------------ start of error message ----------------------
Command failed: ./utilbin/lx24-x86/spooldefaults configuration
/tmp/configuration

Probably a permission problem. Please check file access permissions.
Check read/write permission. Check if SGE daemons are running.
------------------------ end of error message ------------------------

My environment is:
OS: Redhat Enterprise 4 WS
kernel: 2.6.9-22.EL #1

1. I download 2 files as following URLs
http://gridengine.sunsource.net/download/SGE60/sge-6.0u8-common.tar.gz
http://gridengine.sunsource.net/download/SGE60/sge-6.0u8-bin-lx24-x86.tar.gz
2. untar the 2 tar files
3. set the variable SGE_ROOT
4. set sge_qmaster and sge_execd port in /etc/services
5. execute install_qmaster to install master host

When I finished the configuration parameters, there is a error message
as following:

------------------------ start of error message ----------------------
Do you want to change the configuration parameters (y/n) [n] >>



Command failed: ./utilbin/lx24-x86/spooldefaults configuration
/tmp/configuration

Probably a permission problem. Please check file access permissions.
Check read/write permission. Check if SGE daemons are running.
------------------------ end of error message ------------------------

I have refer the post
http://gridengine.sunsource.net/servlets/ReadMsg?list=users&msgNo=16421
My spool dir was created by install_qmaster.
The directory permission is following:

$ ls -l /usr/local/N1GridEngine6/default/spool/
total 16
drwxr-xr-x 3 root root 4096 Oct 20 06:24 qmaster
drwxr-xr-x 2 root root 4096 Oct 23 03:33 spooldb

$ ls -l /usr/local/N1GridEngine6/default/spool/spooldb/
total 412
-rw------- 1 root root 8192 Oct 23 03:33 __db.001
-rw------- 1 root root 5251072 Oct 23 03:33 __db.002
-rw------- 1 root root 98304 Oct 23 03:33 __db.003
-rw------- 1 root root 368640 Oct 23 03:33 __db.004
-rw------- 1 root root 16384 Oct 23 03:33 __db.005
-rw------- 1 root root 17780 Oct 23 03:33 log.0000000001
-rw------- 1 root root 8192 Oct 23 03:33 sge
-rw------- 1 root root 8192 Oct 23 03:33 sge_job


How to solve the probelm? Thanks.


the /tmp/configuration is following:
---------------------- start of conf. file ------------------------
# Version: 6.0u8
#
# DO NOT MODIFY THIS FILE MANUALLY!
#
conf_version 0
execd_spool_dir /usr/local/N1GridEngine6/default/spool
mailer /bin/mail
xterm /usr/bin/X11/xterm
load_sensor none
prolog none
epilog none
shell_start_mode posix_compliant
login_shells sh,ksh,csh,tcsh
min_uid 0
min_gid 0
user_lists none
xuser_lists none
projects none
xprojects none
enforce_project false
enforce_user auto
load_report_time 00:00:40
max_unheard 00:05:00
reschedule_unknown 00:00:00
loglevel log_warning
administrator_mail admin at my.server
set_token_cmd none
pag_cmd none
token_extend_time none
shepherd_cmd none
qmaster_params none
execd_params none
reporting_params accounting=true reporting=false flush_time=00:00:15
joblog=false sharelog=00:00:00
finished_jobs 100
gid_range 3001-3500
qlogin_command telnet
qlogin_daemon /usr/sbin/in.telnetd
rlogin_daemon /usr/sbin/in.rlogind
max_aj_instances 2000
max_aj_tasks 75000
max_u_jobs 0
max_jobs 0
auto_user_oticket 0
auto_user_fshare 0
auto_user_default_project none
auto_user_delete_time 86400
delegated_file_staging false
reprioritize 0
------------------------ end of conf. file ------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list