[GE users] Missing slots

Reuti reuti at staff.uni-marburg.de
Wed Aug 1 12:26:54 BST 2007


Am 31.07.2007 um 18:18 schrieb Heywood, Todd:

> I have a situation where SGE seems to only see one slot per host  
> even though
> I have defined 4 slots per host. There is a single queue on these  
> hosts.
> Here is an example, showing 1 slot available (0 used) on blade10:
>
> [root at bhmnode2 bh_admin]# qhost -h blade10 -q
> HOSTNAME                ARCH         NCPU  LOAD  MEMTOT  MEMUSE   
> SWAPTO
> SWAPUS
> ---------------------------------------------------------------------- 
> ------
> ---
> global                  -               -     -       -        
> -       -
> -
> blade10                 lx24-amd64      4  0.00    3.9G   54.2M     
> 1.0G
> 20.8M
>    public.q             BIP   0/1
> [root at bhmnode2 bh_admin]#
>
>
> Now, in the definition of public.q, I have 4 slots per host  
> (blade10 is in
> the publichosts hostgroup) defined in this line:
>
> slots                 1,[@publichosts=4]

Just to be sure: can you please post the result of:

qconf -shgrp @publichosts

And if the workload allows it: you can just define 4 as default, and  
check whether the output qhost -q changes. Is it the same as in qstat  
-f regarding the slots?

-- Reuti

>
> And the local host config is also defined with 4 slots:
>
> [root at bhmnode2 lx24-amd64]# qconf -se blade10
> hostname              blade10
> load_scaling          NONE
> complex_values        virtual_free=3.8G,slots=4
> <<snip>>
>
> The strange thing is that this is the case for only about 5% of the  
> hosts in
> the publichosts hostgroup.
>
> Any ideas? Thanks.
>
> Todd Heywood
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list