[GE users] logchecker question

Reuti reuti at staff.uni-marburg.de
Mon Aug 13 23:13:42 BST 2007


Hi,

Am 13.08.2007 um 20:09 schrieb Brett_W_Grant at raytheon.com:

> I finally got around to setting up and configuring the logchecker  
> script.  This is 6.1 on mac osx.  Anyway, at first it would not  
> run.  Turns out that the PATH variable had to have /bin included.

how did you start the script`

> Also, it kept having problems with the spooler directories, it  
> turns out that the variable execd_spool_dir was not getting set.  I  
> don't know if this is error or a bug or something that only occurs  
> on mac os.

You are using the crontab or launchd?

> Anyway, I just added a line:
>
> execd_spool_dir=$SGE_ROOT/$SGE_CELL/spool

You could also use the parameter:

-execd_spool /var/spool/sge

to the script, i.e. in our cron.d/gridware on the nodes I put:

reuti at node:/etc/cron.d> cat gridengine
PATH=/usr/bin:/usr/sbin:/sbin:/bin:/usr/lib/news/bin
#
# Special cron-job to reduce the size of the SGE messages/accounting/ 
statistics  files.
#
5 1 * * 0       sgeadmin        /usr/sge/default/common/logchecker.sh  
-action_on 2 -execd_spool /var/spool/sge

(to avoid the configured script to be overridden by an upgrade, I  
copied it to this locaction)

-- Reuti

> does anyone see any problems with that?
>
> Thanks,
> Brett Grant

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list