[GE users] RE: cannot submit job because of error bug?

SLIM H.A. h.a.slim at durham.ac.uk
Wed Aug 29 10:39:50 BST 2007


Dear Daniel

I have set dl 4 and attach the output. I had a look at the source, is it
possible to build qstat by itself for debug purpose?

Thanks

Henk

> -----Original Message-----
> From: Dan.Templeton at Sun.COM [mailto:Dan.Templeton at Sun.COM] 
> Sent: 28 August 2007 19:07
> To: users at gridengine.sunsource.net
> Subject: Re: [GE users] RE: cannot submit job because of error bug?
> 
> The debug levels aren't monotonic.  10 is actually less 
> information than some lower levels.  4 might give you more info.  See:
> 
> http://blogs.sun.com/templedf/entry/using_debugging_output
> 
> Daniel
> 
> SLIM H.A. wrote:
> > Further information to the failure of the sge commands for 
> some unix 
> > groups of users.
> >  
> > Setting the debug level to 10 and running the qstat command 
> gives for 
> > the last few lines of stdout:
> >
> >     63  15359 47241863851776 		--> sge_log() {
> >     64  15359 47241863851776     sge_log: ctx is NULL
> >     65  15359 47241863851776     
> ../libs/sgeobj/sge_answer.c 937 can't
> > resolve group
> >
> > I attached the full debug output.
> >
> > Thanks
> >
> > Henk
> >
> >   
> >> -----Original Message-----
> >> From: SLIM H.A. 
> >> Sent: 28 August 2007 16:46
> >> To: SLIM H.A.
> >> Subject: cannot submit job because of error bug?
> >>
> >>  
> >>
> >> Some users are unable to submit jobs under sge 6.1. The 
> error message 
> >> is this:
> >>
> >> % qsub
> >> Unable to initialize environment because of error: can't resolve 
> >> group
> >>     
> >
> >   
> >> Exiting.
> >>
> >>
> >> It appears that a limit is hit by the grid engine commands when 
> >> reading one of the secondary group entries in the 
> /etc/group file. It 
> >> seems the commands cannot process lines that have more than some 
> >> small
> >>     
> >
> >   
> >> number of charcters, probably 512.
> >> Any userid that has that particular offending secondary 
> group as its 
> >> primary group cannot submit jobs.
> >>
> >> When the number of userids for the offending secondary group is 
> >> reduced, the userid is able to submit again.
> >>
> >> Is this a bug as 6.0u7 did not have this problem?
> >>
> >> Thanks for any advice
> >>
> >>
> >> Henk
> >>
> >>     
> >>> -----Original Message-----
> >>> From: SLIM H.A. 
> >>> Sent: 28 August 2007 11:34
> >>> To: 'users at gridengine.sunsource.net'
> >>> Subject: RE: [GE users] 6.1: critical error: can't resolve group
> >>>
> >>> Chris,
> >>>
> >>> I tried this, it seems to be ok:
> >>>
> >>> # grpck
> >>> Checking `/etc/group' 
> >>>
> >>> is the only response I get
> >>>
> >>> Thanks
> >>>
> >>> Henk
> >>>
> >>>
> >>>
> >>>       
> >>>> -----Original Message-----
> >>>> From: chris.harwell at novartis.com
> >>>>         
> >> [mailto:chris.harwell at novartis.com]
> >>     
> >>>> Sent: 28 August 2007 11:03
> >>>> To: users
> >>>> Subject: Re: [GE users] 6.1: critical error: can't resolve group
> >>>>
> >>>> Try running grpck as root. 
> >>>>
> >>>>
> >>>>
> >>>> ----- Original Message -----
> >>>> From: "SLIM H.A." [h.a.slim at durham.ac.uk]
> >>>> Sent: 08/28/2007 04:56 AM
> >>>> To: <users at gridengine.sunsource.net>
> >>>> Subject: [GE users] 6.1: critical error: can't resolve group
> >>>>
> >>>>
> >>>> I just upgraded from 6.0u7 to 6.1 and have come across a
> >>>>         
> >>> problem. The
> >>>       
> >>>> Grid Engine commands now give for some users an error, 
> for example
> >>>>
> >>>> %qstat
> >>>> critical error: can't resolve group
> >>>>
> >>>> Has anyone seen this before or have an idea why this now 
> shows up?
> >>>>
> >>>> Thanks
> >>>>
> >>>> Henk
> >>>>
> >>>>
> >>>>         
> >> 
> ---------------------------------------------------------------------
> >>     
> >>>> To unsubscribe, e-mail: 
> users-unsubscribe at gridengine.sunsource.net
> >>>> For additional commands, e-mail: 
> >>>>         
> >> users-help at gridengine.sunsource.net
> >>     
> >>>>         
> >> 
> ---------------------------------------------------------------------
> >>     
> >>>> To unsubscribe, e-mail: 
> users-unsubscribe at gridengine.sunsource.net
> >>>> For additional commands, e-mail: 
> >>>>         
> >> users-help at gridengine.sunsource.net
> >>     
> >>>>         
> >>>> 
> -------------------------------------------------------------------
> >>>> -----
> >>>>
> >>>> 
> -------------------------------------------------------------------
> >>>> -- To unsubscribe, e-mail: 
> >>>> users-unsubscribe at gridengine.sunsource.net
> >>>> For additional commands, e-mail: 
> >>>> users-help at gridengine.sunsource.net
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
> 
> 


    [ Part 2, "qstat_dl_4.txt"  Text/PLAIN (Name: "qstat_dl_4.txt") ~3.4 ]
    [ KB. ]
    [ Unable to print this part. ]


    [ Part 3: "Attached Text" ]

    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net



More information about the gridengine-users mailing list