[GE users] Changing xterm value has no effect

Tod Hagan tod at gust.sr.unh.edu
Thu Aug 30 18:19:42 BST 2007


Hi all,

I'm trying to get interactive X-windows sessions working using qsh on
ge6.1_lx24-x86. 

Since xterm is not located in /usr/bin/X11/xterm, 'qconf -mconf' was
used to change xterm, yet as shown below qsh continues to fail looking
for /usr/bin/X11/xterm:

        prompt> cat /etc/redhat-release 
        Red Hat Enterprise Linux Server release 5 (Tikanga)
        prompt> which xterm
        /usr/bin/xterm
        prompt> qconf -sconf | grep xterm
        xterm                        /usr/bin/xterm
        prompt> qsh
        Your job 190 ("INTERACTIVE") has been submitted
        waiting for interactive job to be scheduled ...
        
        Your "qsh" request could not be scheduled, try again later.
        prompt> tail -2 /opt/ge6.1_lx24-x86/default/spool/qmaster/messages
        08/30/2007 13:01:46|qmaster|nodename|W|job 190.1 failed on host node116.localdomain general before job because: 08/30/2007 13:01:45 [1125:31939]: unable to find xterm executable "/usr/bin/X11/xterm" for interactive job
        08/30/2007 13:01:46|qmaster|nodename|E|queue all.q marked QERROR as result of job 190's failure at host node116.localdomain
        prompt>

Should I just symlink xterm to /usr/bin/X11/xterm on all the execution
hosts, or is there some way I can get gridengine to change where it
looks for xterm?

Thanks in advance.

Tod

-- 
Tod Hagan
Information Technologist
AIRMAP/Climate Change Research Center
Institute for the Study of Earth, Oceans, and Space
University of New Hampshire
Durham, NH 03824
Phone: 603-862-3116


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list