[GE users] Troubles installing SGE exec_d on windows

Harald Pollinger Harald.Pollinger at Sun.COM
Thu Dec 13 16:46:33 GMT 2007


    [ The following text is in the "ISO-8859-15" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

nico duce wrote:
> Hi Harald,
> 
> I'm using SGE 6.1 update 2.
> I had installed the master host as root (maybe that is a problem ?)

Well, it should work, but it is rarely used. It's recommended to install 
as SGE admin user.

Regards,
Harald


> Addind the user Administrator to the manager lists worked, but it stops 
> when the  installation script tries to create the admin user.
> 
> Now Im reading this nice paper with a lot of information   about 
> installing SGE on windows hosts, it says that you must have a domain to 
> make it work.
>   http://www.0x1b.ch/misc/papers/sge/
> 
> Thanks
> Nico
> 
> On Dec 12, 2007 12:33 PM, Harald Pollinger <Harald.Pollinger at sun.com 
> <mailto:Harald.Pollinger at sun.com>> wrote:
> 
>     nico duce wrote:
>      > I installed sge on linux Fedora Core 4, I have master and execution
>      > hosts working, but when I try to install a windows execution
>     host, the
>      > instalation script gives me this message:
>      >
>      > /*The admin user >POST1+default< doesn't match the admin username
>      >  >POST1+none< in the global cluster configuration
>      > */
> 
>     Nico, could you please tell me which SGE version you are using?
> 
>     You did install SGE as a 'root system' with no SGE admin user, right?
>     I.e. the $SGE_ROOT/$SGE_CELL/common/bootstrap file contains the entry
>     "admin_user  none" and all daemons are started by root (or on Windows:
>     the local Administrator), right?
> 
>     I think there is a validity test that is too strict on Windows in this
>     special case.
> 
>     As a workaround please try to set the "admin_user" entry in the
>     bootstrap file to a valid user name, e.g. "admin_user nico", to install
>     the Windows execution host. Set it back to "none" after the
>     installation.
> 
>     Regards,
>     Harald
> 
> 
>      > POST1 is the name of the windows host Im trying to add to the
>     cluster. I
>      > had created the csp certificates on the master host for root user.
>      >
>      > I would appreciate any help !
>      >
>      > thanks
>      > Nico
-- 
Sun Microsystems GmbH         Harald Pollinger
Dr.-Leo-Ritter-Str. 7         N1 Grid Engine Engineering
D-93049 Regensburg            Phone: +49 (0)941 3075-209  (x60209)
Germany                       Fax: +49 (0)941 3075-222  (x60222)
http://www.sun.com/gridware
mailto:harald.pollinger at sun.com
Sitz der Gesellschaft: Sonnenallee 1, D-85551 Kirchheim-Heimstetten
Amtsgericht Muenchen: HRB 161028
Geschaeftsfuehrer: Thomas Schroeder, Wolfgang Engels, Dr. Roland Boemer
Vorsitzender des Aufsichtsrates: Martin Haering

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list