[GE users] qmake job and errors: pid: No such file or directory

Reuti reuti at staff.uni-marburg.de
Fri Dec 28 22:16:51 GMT 2007


Hi,

Am 28.12.2007 um 22:15 schrieb Sean Davis:

> I am trying to run qmake on the Solexa analysis pipeline (probably  
> not important, but....).  When I run this command, I get the  
> following error:
>
> can't open file /tmp/285.1.all.q/pid: No such file or directory
>
> I have the shepherd trace available, also.  Does this problem ring  
> any bells for anyone?
>
> As for details of our setup, we have several linux boxes running  
> the lx24-amd64 binaries (though they are intel machines).  All are  
> using ssh for communication.  None has a firewall enabled.  They  
> are using shared home directories, but /tmp, etc., are local to the  
> machines.  Qlogin, qrsh, and qsh seem to be working.  We have  
> openmpi installed, also.
>
> I know the question is pretty vague.  I am pretty new to SGE, so  
> debugging these issues is pretty new also.  Any guidance is  
> appreciated.

usually the 'pid' file should go to a spool directory like:

$SGE_ROOT/spool/sge/<node>/active_jobs/<job_id>.<task_id>

or better:

/var/spool/sge/<node>/active_jobs/<job_id>.<task_id>

and not the local tmp directory for the job. Where is the spool  
directory for the node: local or on the NFS server? Best would be to  
have it local on all nodes:

http://gridengine.sunsource.net/howto/nfsreduce.html

-- Reuti

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list