[GE users] mixing 6.0u7 and 6.0u10

Daniel Templeton Dan.Templeton at Sun.COM
Wed Feb 7 18:36:07 GMT 2007


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Brooks,

In general, it's a bad idea to mix SGE versions.  In many cases, SGE 
itself will prevent it.  The protocol used to communicate with the 
qmaster (GDI) is versioned.  Any time that protocol changes, the version 
gets revved.  To be able to talk to each other, both components must be 
using the same version of the protocol.

Here's a blog post I wrote about the topic a while back:

http://blogs.sun.com/templedf/entry/the_secret_of_the_gdi

Daniel

Brooks Davis wrote:
> Is it possible/supported to mix updates of SGE?  In the past it's worked
> for me, but with a u7 qmaster, I'm seeing execd not start and qstat fail
> with:
>
> error: can't unpack gdi request
> error: error unpacking gdi request: bad argument
> failed receiving gdi request
>
> I get similar errors when stoping the execd.  At this point it looks
> like I'll need to install an older version and have a flag day in the
> future.
>
> -- Brooks
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list