[GE users] mixing 6.0u7 and 6.0u10

Dev dev_hyd2001 at yahoo.com
Thu Feb 8 16:17:27 GMT 2007


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Well what I was wondering about was more close to Dan's comments. I was wondering if there could be a standard interface across DRMS like SGE, Torque etc using which we can get information about configurations ( similar to JGDI ? ), atleast for those parameters which are common to most of the DRMS like queue-names, nodes, slots etc. 

Andreas.Haas at Sun.COM wrote: Hi Dan,

I believe Dev merely asks whether a DRMAA library from a concrete 
Grid Engine update version could instantly tell the application 
if there is a GDI version protocol conflict.

Regards,
Andreas

On Wed, 7 Feb 2007, Daniel Templeton wrote:

> Not sure I see the value of standardizing internal data formats.  It would 
> also be impossible from a political standpoint.  More useful is standardizing 
> the interfaces, and that's what *many* of the OGF working and research groups 
> are doing, such as DRMAA, JSDL, SAGA, etc.  The trick is getting vendors to 
> adopt them.
>
> Daniel
>
> Dev wrote:
>> Just a "Would like it to be this way" thought. Isn't it possible to frame a 
>> standard like DRMAA for the way the DRMS store their internal info?  I know 
>> its not that easy :-((
>> 
>> 
>> /Dev
>> 
>> 
>> 
>>
>> 
>> */Daniel Templeton /* wrote:
>>
>>     Brooks,
>>
>>     In general, it's a bad idea to mix SGE versions. In many cases, SGE
>>     itself will prevent it. The protocol used to communicate with the
>>     qmaster (GDI) is versioned. Any time that protocol changes, the
>>     version
>>     gets revved. To be able to talk to each other, both components
>>     must be
>>     using the same version of the protocol.
>>
>>     Here's a blog post I wrote about the topic a while back:
>>
>>     http://blogs.sun.com/templedf/entry/the_secret_of_the_gdi
>>
>>     Daniel
>>
>>     Brooks Davis wrote:
>>     > Is it possible/supported to mix updates of SGE? In the past it's
>>     worked
>>     > for me, but with a u7 qmaster, I'm seeing execd not start and
>>     qstat fail
>>     > with:
>>     >
>>     > error: can't unpack gdi request
>>     > error: error unpacking gdi request: bad argument
>>     > failed receiving gdi request
>>     >
>>     > I get similar errors when stoping the execd. At this point it looks
>>     > like I'll need to install an older version and have a flag day
>>     in the
>>     > future.
>>     >
>>     > -- Brooks
>>     >
>>     >
>>     ---------------------------------------------------------------------
>>     > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>     > For additional commands, e-mail: users-help at gridengine.sunsource.net
>>     >
>>     >
>>
>>     ---------------------------------------------------------------------
>>     To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>     For additional commands, e-mail: users-help at gridengine.sunsource.net
>> 
>> 
>> ------------------------------------------------------------------------
>> Finding fabulous fares is fun.
>> Let Yahoo! FareChase search your favorite travel sites 
>>  
>> to find flight and hotel bargains. 
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net



 
---------------------------------
Any questions?  Get answers on any topic at Yahoo! Answers. Try it now.



More information about the gridengine-users mailing list