[GE users] commlib errors with csp-installation

Chinu chinu at web.de
Wed Feb 21 10:19:40 GMT 2007


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Thank you!

I did a fresh install and got it working. What I did:

on the Master Host computer:
su
./install_qmaster -csp

note: I installed as admin user >sgeadmin< so I did:
. /opt/n1ge6/default/common/settings.sh
. /opt/n1ge6/util/sgeCA/sge_ca -copy

Then I manually copied the certificates to the Execution Host computers like this:
scp -r /var/sgeCA/ root at sge_host_A:/var

On the Execution Host computers I did:
chown -R sgeadmin /var/sgeCA/
./install_execd -csp

Now the Execution Hosts are running and processing the jobs :-)

Regards,
Chinu




Andre Alefeld wrote:
> Hi,
> 
> did you copy the certificates generated on the master over to the execds ?
> The process is outlined in the N1 Grid Engine Installation Manual
> (http://docs.sun.com/app/docs/doc/817-6118  Chapter 4)
> 
> Andre
> 
> Chinu schrieb:
>> Hello!
>>
>> I am using the Sun Grid Engine 6u8. After using it without the
>> Certificate
>> Security Protocol (CSP). I tried to install the Sun Grid Engine with
>> the -csp
>> option but regardless which user I use (root or sgeadmin) and which
>> file-permission I set for /opt/n1ge6 and /var/sgeCA I cannot install it.
>>
>> I got the Master Host running but the Execution Hosts won't start.
>>
>> On the Execution Hosts I get the following errors:
>> 02/21/2007 01:09:27|execd|sge_host_B|E|communication error for
>> "sge_host_B.xxx/execd/1" running on port 40001: "can't set private key
>> pem file"
>> 02/21/2007 01:09:28|execd|sge_host_B|E|commlib error: can't set
>> private key pem
>> file (/var/sgeCA/port40000/default/userkeys/sgeadmin/key.pem)
>> 02/21/2007 01:09:28|execd|sge_host_B|E|commlib error: ssl error
>> ([ID=185073780]
>> in module "x509 certificate routines": "key values mismatch")
>> 02/21/2007 01:09:28|execd|sge_host_B|E|commlib error: can't set
>> private key pem
>> file (no additional information available)
>> 02/21/2007 01:09:56|execd|sge_host_B|C|abort execd startup due to
>> communication
>> errors
>>
>> I think I am missing something basic. But I don't finde it. Does
>> anybody have an
>> idea, what is wrong?
>>
>> Regards,
>> Chinu
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>
>>   
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list