[GE users] lam tight and host names

Reuti reuti at staff.uni-marburg.de
Wed Feb 28 13:58:51 GMT 2007


Hi,

Am 28.02.2007 um 14:23 schrieb Davide Cittaro:

> Hi all, it seems I have some problems here in hostnames handling. I  
> have long names defined in sge
>
> qconf -sel
> <snip>

in the startlam.sh script the defined PeHostfile2MachineFile() may  
remove the last part:

Try changing:

       host=`echo $line|cut -f1 -d" "|cut -f1 -d"."`

to

       host=`echo $line|cut -f1 -d" "`

-- Reuti


> but as I start mpi scripts (tigthly integrated) I have errors like  
> this:
>
> cat clustest.sh.pe3167
> ---------------------------------------------------------------------- 
> -------
> Could not resolve the hostname "node1" that was in the host file.
>
> Things to check:
>
>         - is "node1" in /etc/hosts?
>           try "grep node1 /etc/hosts"
>         - is "node1" resolvable by DNS (or some other naming service)?
>           try "ping node1" or "dig node1" or "nslookup node1"
> ---------------------------------------------------------------------- 
> -------
>
> Of course I cannot define node1 in /etc/hosts, since it would be  
> ambiguous for node1.xtal and node1.sge.
> What should I hack to make lam get a correct list of hostnames?
>
> d
> /*
> Davide Cittaro
> HPC and Bioinformatics Systems @ Informatics Core
>
> IFOM - Istituto FIRC di Oncologia Molecolare
> via adamello, 16
> 20139 Milano
> Italy
>
> tel.: +39(02)574303007
> e-mail: davide.cittaro at ifom-ieo-campus.it
> */
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list