[GE users] meaning of 256 error code...

Gon?alo Borges goncalo at lip.pt
Fri Jul 6 11:34:05 BST 2007


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi Daniel,
>
>
> If $? is 256, the backticked command is exiting with exit code 1.  
> Could it be something simple like a space in $sge_base_path or 
> $sge_job_script_name?  Maybe when you print $submit_status, if it's 
> non-zero you should also print $tmp_batch_id so you can see what the 
> failure message is.
>

I just tried that and $tmp_batch_id just comes up as an empty variable...


> BTW, with 6.1u1, you can use qsub -terse, and skip having to parse out 
> the job id.
>
> Daniel
>
> Gon?alo Borges wrote:
>> So...
>> The wrapper which submits the jobs is a perl script. The part where 
>> it submits is just something like:
>>
>>        do
>>        {
>>                chomp($tmp_batch_id = `export SGE_ROOT=$sge_base_path 
>> ;$qsub < $sge_job_script_name`);
>>                $submit_status = $?;
>>                if($tmp_batch_id =~ /^Your job (\d*)/) {
>>                        $batch_id = $1;
>>                }
>>
>>                $self->log("Batch ID: " . $batch_id);
>>
>>                if ($submit_status != 0)
>>                {
>>                        $batch_id = undef;
>>                        sleep 5;
>>                }
>>                $attempts++;
>>        } while($submit_status != 0 && $attempts<6);
>>
>> I see the error message because I print the $submit_status 
>> variable... And that's it...
>> In the qmaster logs 
>> "/usr/local/sge/pro/default/spool/qmaster/messages" I do not see 
>> nothing at all...
>>
>> It's very hard to ask for help when you do not have any relevant 
>> information...
>> Sorry...
>>
>>
>>
>> Rayson Ho wrote:
>>> So, what *exactly* do you see in the logs??
>>>
>>> Can you just copy and paste the message??
>>>
>>> Rayson
>>>
>>>
>>>
>>> On 7/5/07, Gon?alo Borges <goncalo at lip.pt> wrote:
>>>>
>>>> SGE seems to be properly running when I assume a grid user identity 
>>>> and
>>>> submit directly to the batch system...
>>>> But when it goes through all the middlware chain, it fails with this
>>>> kind of errors... I see it in the middlware logs...
>>>>
>>>>
>>>>
>>>> Rayson Ho wrote:
>>>> > Are you getting it from the exit code via the shell scripts, or are
>>>> > you getting it from the error message printed to the log files??
>>>> >
>>>> > Rayson
>>>> >
>>>> >
>>>> >
>>>> > On 7/5/07, Gon?alo Borges <goncalo at lip.pt> wrote:
>>>> >> I'm using SLC 3.0.8 and I'm trying to integrate SGE in glite, 
>>>> the EGEE
>>>> >> middleware...
>>>> >> So, there are so many wrappers that I'm not sure how to 
>>>> reproduce it the
>>>> >> context where I get this error...
>>>> >> :(
>>>> >> Gon?alo
>>>> >>
>>>> >> Rayson Ho wrote:
>>>> >> > What OS is it?? And how to reproduce it??
>>>> >> >
>>>> >> > Exit code is supposed to be from 0-255...
>>>> >> >
>>>> >> > http://tldp.org/LDP/abs/html/exitcodes.html
>>>> >> >
>>>> >> > Rayson
>>>> >> >
>>>> >> >
>>>> >> >
>>>> >> > On 7/5/07, Gon?alo Borges <goncalo at lip.pt> wrote:
>>>> >> >> Hi there,
>>>> >> >>
>>>> >> >> When I try to submit to SGE I get the exit code 256... I'm not
>>>> >> able to
>>>> >> >> find its meaning... Do you know what it is?
>>>> >> >> Cheers
>>>> >> >> Goncalo
>>>> >> >>
>>>> >> >> 
>>>> ---------------------------------------------------------------------
>>>> >> >> To unsubscribe, e-mail: 
>>>> users-unsubscribe at gridengine.sunsource.net
>>>> >> >> For additional commands, e-mail: 
>>>> users-help at gridengine.sunsource.net
>>>> >> >>
>>>> >> >>
>>>> >> >
>>>> >> > 
>>>> ---------------------------------------------------------------------
>>>> >> > To unsubscribe, e-mail: 
>>>> users-unsubscribe at gridengine.sunsource.net
>>>> >> > For additional commands, e-mail: 
>>>> users-help at gridengine.sunsource.net
>>>> >>
>>>> >> 
>>>> ---------------------------------------------------------------------
>>>> >> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>>> >> For additional commands, e-mail: 
>>>> users-help at gridengine.sunsource.net
>>>> >>
>>>> >>
>>>> >
>>>> > 
>>>> ---------------------------------------------------------------------
>>>> > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>>> > For additional commands, e-mail: users-help at gridengine.sunsource.net
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>>>
>>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>
>
>
> ------------------------------------------------------------------------
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list