[GE users] No job status, but process still runs

Olesen, Mark Mark.Olesen at emcontechnologies.com
Mon Jul 9 20:19:29 BST 2007


    [ The following text is in the "X-UNKNOWN" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

> I tried using the bash wait command but it's not capturing the PID. I
> also tried using fghack to no avail.
> 
> Are there any resources I can look up on how to set up my wrapper
> script?

The preferred choice would be to get the software vendor to give you
information about how avoid forking or else implement this functionality
very soon.

The only other possibility is brute force.
By inspection, try to see what PID/PGRP type of rules seem to be followed
when you start the process by hand (w/o GridEngine).
If there is just one of these jobs per machine/user, you could simply grep
the ps table for the appropriate PID.

If the shell wait on pid gives you problems, you could also try a simple
Perl script with sleeping, querying the PID, etc.



More information about the gridengine-users mailing list