[GE users] Sort by sequence number question

Andreas.Haas at Sun.COM Andreas.Haas at Sun.COM
Wed Jul 18 15:31:31 BST 2007


Hi Ravi,

On Wed, 18 Jul 2007, Ravi Chandra Nallan wrote:

> Hi Andreas,
>
> Andreas.Haas at Sun.COM wrote:
>> On Tue, 17 Jul 2007, Paul MacInnis wrote:
>> 
>>> The jobs here have no -soft options but they do have load thresholds:
>>> 
>>> qname                 ser.q
>>> hostlist              @1g.hg @2g.hg @4g.hg
>>> seq_no                1965,[@2g.hg=2965],[@4g.hg=4965]
>>> load_thresholds       load_avg=1.5,mem_used=500M,[@2g.hg=load_avg=1.5, \
>>>                      mem_used=1.5G],[@4g.hg=load_avg=1.5,mem_used=3.5G]
>>> suspend_thresholds    NONE
>>> 
>>> qname                 bg.q
>>> hostlist              @2g.hg @4g.hg
>>> seq_no                2969,[@4g.hg=4969]
>>> load_thresholds       load_avg=1.5,mem_used=1.5G,[@4g.hg=load_avg=1.5, \
>>>                      mem_used=3.5G]
>>> suspend_thresholds    load_avg=2.5
>>> 
>>> Each 2G and 4G node has a ser.q and a bg.q queue instance, each with same
>>> load_thresholds, but scheduler has a definite preference for the bg.q
>>> instance, inspite of the higher seqno!  Perhaps in time an explanation
>>> will appear ...
>> 
>> Could you try whether behaviour changes anyhow when you set load_thresholds
>> to NONE with both queues? Just temporarily for testing purposes. Load 
>> thresholds make setups always hard to survey, whereas setups without load 
>> thrsholds are fairly deterministic.
>> 
>> Andreas
> But does load_threshold play a role in choosing the queue when the 
> queue_sort_method is set seqno?

Sure it does.

> And if load_threshold were to make a queue unusable, wouldn't the q be set to 
> alarm state?

Sure.

> Also I noticed that Erik was able to reproduce the prob with pe jobs. I am 
> not sure if the array jobs had a similar problem.

To me these are two different problems: (a) With Eriks parallel job allocation 
problem I already fail to understand why it behaved the way as he described it 
for 5.3 and how he needs it, whereas (b) Pauls sequential job problem looks to me 
like the outcome confusing load thresholds setup.

> I couldn't reproduce it with neither pe not array jobs, must be some setting 
> that is effecting it.

Yep. At least Pauls basic setup worked in my cluster here. For that
reason I asked Paul to disable load thresholds temporarily.

Regards,
Andreas

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list