[GE users] SGE 6.1 and qsh failure

Barry McInnes Barry.J.Mcinnes at noaa.gov
Thu Jul 19 21:58:26 BST 2007


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Thanks for the information - see below for responses.

On 7/19/07 1:41 PM, Reuti wrote:
> Am 18.07.2007 um 17:51 schrieb Barry McInnes:
> 
>> Running SGE 6.1 and Mac X 10.4.10
>> qlogin and qrsh work fine via the ql.sh script
> 
> You are running the commands from the X11 application, not the terminal
> application - right?
> 

Yes all from X11, with DISPLAY set and xhost +


> 
> You want a safe ssh connection to the node but then use an unsafe direct
> X11 connection back?
> 
> AFAIK there is no qsh_command entry. qsh will just start the program you
> set in the global (or node) configuration for "xterm
> /usr/bin/X11/xterm". Often it's working to use just:
> 
> qrsh xterm

qrsh works fine as does qlogin

> 
> if you setup your ssh-wrapper in SGE to have the option -Y or put this
> option in the global /etc/ssh/ssh_config or private ~/.ssh/config like:
> 
> Host *
>     ForwardAgent yes
>     ForwardX11 yes
>     ForwardX11Trusted yes
>     Compression yes
>     NoHostAuthenticationForLocalhost yes
>     ServerAliveInterval 900
> 

I tried the above settings in private config file, with no gain.
All macs have been setup to use passwordless, so this works
[mac27:~/.ssh] bmcinnes% ssh mac05
[mac05:~] bmcinnes%

> (and maybe it's of interest: optionally have on the Mac the
> http://www.phil.uu.nl/~xges/blog/ssh running with the same options you
> could even use a passphrase in your ssh-keys without the need to enter
> it all the time. A good explanation for the use of the ssh-agent I found
> here: http://www.unixwiz.net/techtips/ssh-agent-forwarding.html).
> 

If there is no obvious solution, I will live without qsh, but here is
the same tests as in the first email after using the above config.

mac27:~/.ssh] bmcinnes% qsh -display :0.0 -e -v
error: local DISPLAY variable ":0.0" delivered with interactive job
[mac27:~/.ssh] bmcinnes% qsh -display mac27:0.0 -e -v
Your job 34871 ("INTERACTIVE") has been submitted
waiting for interactive job to be scheduled ...
Could not start interactive job.
[mac27:~/.ssh] bmcinnes% qsh -display mac27.cdc.noaa.gov:0.0 -e -v
Your job 34872 ("INTERACTIVE") has been submitted
waiting for interactive job to be scheduled ...
Could not start interactive job.
[mac27:

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list