[GE users] SGE 6.1 and qsh failure

Barry McInnes Barry.J.Mcinnes at noaa.gov
Fri Jul 20 18:53:38 BST 2007


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]


> 
> rsh_command     /usr/bin/ssh -X -Y
> 
> and
> 
> qrsh xterm
> 
> should work.
>
Some success :-) Thanks for all the help

I added the rsh commands to conf, but still use the ql.sh script.
When I run "qrsh xterm" is uses the ql.sh script and the script as given
in the docs, does not pass the extra exec paramters.
When I add this to the ql.sh ssh command line I do get an xterm from the
cluster.
To make qlogin and qrsh to work via ql.sh I have to swap the input
parameters around.

HOST=$3
PORT=$2
case $1 in
 mac*) HOST=$1;
esac
case $3 in
 mac*) HOST=$3;
esac

PORT=22
/usr/bin/ssh -X -Y -p $PORT $HOST $4 $5 $6


But qsh still gives the same error, and does not use ql.sh even though
my conf has
qlogin_command               /usr/local/sge/ql.sh
qlogin_daemon                /usr/sbin/sshd -i
rlogin_command               /usr/local/sge/ql.sh
rlogin_daemon                /usr/sbin/sshd -i
rsh_command                  /usr/local/sge/ql.sh
rsh_daemon                   /usr/sbin/sshd -i

there must be another definition that qsh uses, ot it just fails to
schedule so it dosnt make it to the al.sh script ?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list