[GE users] SGE 6.1 and qsh failure

Reuti reuti at staff.uni-marburg.de
Fri Jul 20 19:57:43 BST 2007


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Am 20.07.2007 um 19:53 schrieb Barry McInnes:

>> rsh_command     /usr/bin/ssh -X -Y
>>
>> and
>>
>> qrsh xterm
>>
>> should work.
>>
> Some success :-) Thanks for all the help
>
> I added the rsh commands to conf, but still use the ql.sh script.
> When I run "qrsh xterm" is uses the ql.sh script and the script as  
> given
> in the docs, does not pass the extra exec paramters.
> When I add this to the ql.sh ssh command line I do get an xterm  
> from the
> cluster.
> To make qlogin and qrsh to work via ql.sh I have to swap the input
> parameters around.

As stated in the Howto, you need this script only for qlogin. If you  
revert your setup to the Howto settings, it should work.

> HOST=$3
> PORT=$2
> case $1 in
>  mac*) HOST=$1;
> esac
> case $3 in
>  mac*) HOST=$3;
> esac
>
> PORT=22
> /usr/bin/ssh -X -Y -p $PORT $HOST $4 $5 $6

No, don't use port 22. This will not use the SGE started sshd on the  
node, but the system sshd. This means of course to diable the  
firewall on the nodes.

> But qsh still gives the same error, and does not use ql.sh even though
> my conf has
> qlogin_command               /usr/local/sge/ql.sh
> qlogin_daemon                /usr/sbin/sshd -i
> rlogin_command               /usr/local/sge/ql.sh
> rlogin_daemon                /usr/sbin/sshd -i
> rsh_command                  /usr/local/sge/ql.sh
> rsh_daemon                   /usr/sbin/sshd -i
>
> there must be another definition that qsh uses, ot it just fails to
> schedule so it dosnt make it to the al.sh script ?

qsh will not use this settings at all. It will only start the command  
on the node, which is defined in the SGE configuration:

xterm                        /usr/bin/X11/xterm

Nothing is started on your local node. Hence this commmand will not  
work in your environment, as the xterm on the node will only try to  
get access to a port 6000+ on your local machine.

-- Reuti

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list