[GE users] qstat doesn't show job info when run as root?

David Olbersen dolbersen at nextwave.com
Wed Jul 25 23:11:48 BST 2007


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi,

I've Googled around for this a little bit but can't seem to find an
answer. When I run qstat as root I see different output (specifically,
no job info) than when I do it as root.

Have I done something funny in my config, or is this expected behavior?
I've been moving back and forth between different environments and can't
remember if this is consistent or not.

For what it's worth I'm running 6.1 on Linux. $PATH is the same between
both users and they're running the same qstat.

First: Run as the user that submitted the jobs:

% qstat -f -q test.q
queuename                      qtype used/tot. load_avg arch
states
----------------------------------------------------------------------------
test.q at node-4.skunkworks.eng.a BIP   3/10      0.00     lx24-x86      
    243 0.55500 generic-sl dolbersen    r     07/25/2007 15:05:30
1        
    246 0.55500 generic-sl dolbersen    r     07/25/2007 15:05:30
1        
    247 0.55500 generic-sl dolbersen    r     07/25/2007 15:05:30
1        
----------------------------------------------------------------------------
test.q at node-5.skunkworks.eng.a BIP   2/10      0.01     lx24-x86      
    244 0.55500 generic-sl dolbersen    r     07/25/2007 15:05:30
1        
    245 0.55500 generic-sl dolbersen    r     07/25/2007 15:05:30
1        


Second: Run as root:

# qstat -f -q test.q
queuename                      qtype used/tot. load_avg arch
states
----------------------------------------------------------------------------
test.q at node-4.skunkworks.eng.a BIP   3/10      0.00     lx24-x86      
----------------------------------------------------------------------------
test.q at node-5.skunkworks.eng.a BIP   2/10      0.01     lx24-x86      


-- 
David Olbersen <dolbersen at nextwave.com>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list