[GE users] rcmd: socket permission denied using openmpi

Aaron Knister aaron at iges.org
Fri Jul 27 18:47:38 BST 2007


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Make sure rsh is setuid root. Not sure how to do that on solaris but on linux its "chmod u+s /path/to/rsh".

-Aaron

On Jul 27, 2007, at 1:29 PM, Lydia Heck wrote:



	Using openmpi - and currently I am still using rsh - rather than ssh
	I can run an openmpi on Solaris 10 sparc interactively without a problem, but as
	soon as I submit it using sge it fails with

	 rcmd: socket permission

	rsh and rlogin have the permission

	rws--x--x in /opt/SUNWsge/utilbin/sol-sparc64
	I have set
	MPI_MCA_pls_rsh_agent=/usr/bin/rsh

	and this setup works without problem on Solaris10 x86, same version of sge (6.1)
	and same version of openmpi.

	Any suggestions?

	Lydia

	------------------------------------------
	Dr E L  Heck

	University of Durham
	Institute for Computational Cosmology
	Ogden Centre
	Department of Physics
	South Road

	DURHAM, DH1 3LE
	United Kingdom

	e-mail: lydia.heck at durham.ac.uk

	Tel.: + 44 191 - 334 3628
	Fax.: + 44 191 - 334 3645
	___________________________________________

	---------------------------------------------------------------------
	To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
	For additional commands, e-mail: users-help at gridengine.sunsource.net



Aaron Knister
Systems Administrator/
Center for Research on Environment and Water

(301) 595-7001
aaron at iges.org






More information about the gridengine-users mailing list