[GE users] Default queues

Ravi Chandra Nallan Ravichandra.Nallan at Sun.COM
Wed Jun 6 12:18:49 BST 2007


    [ The following text is in the "windows-1252" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Colin Thomas wrote:
>
> Hello,
>
> We have a number of queues set up, for what we define as batch (where 
> a whole cpu is designated to a job) and interactive (where multiple 
> jobs ?share a cpu?).
>
> For the most part we use qsub ?q <queue name>, and all is well? but we 
> have a few users who ?forget? to use the ?q option to qsub, and so 
> their jobs are put on the wrong queues.
>
> Is there a method to either:
>
>    1. To force the specification of a queue
>
use a complex and set requestable to 'forced'. (man complex), assign a 
complex value to every queue.
(instead you can use the built-in complex qname, just set the 
requestable to forced. Then you need not assign it to every queue and it 
can be requested using -l )
> 2. To have a default queue, that unspecified jobs get put to
Set the default requested queue in the 
$SGE_ROOT/$SGE_CELL/common/sge_request
>
> I look forward to your combined wisdom.
>
> Many thanks
>
> Colin Thomas
>
- Ravi

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list