[GE users] Resource Reservation Oddity -- Again

Daniel Templeton Dan.Templeton at Sun.COM
Thu Jun 7 17:07:02 BST 2007


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

I was able to gather a little more data on my RR issues.  There are two 
things going wrong:

1) If I flood the system with low priority (-p -100) jobs, followed by a 
high priority PE1 4 (-p 1000 -pe make 4) job, followed by a less high 
priority PE2 4 (-p 100 -pe mpi 4) job with reservation (-R y), neither 
PE job will be scheduled, which is correct.  The reservation job isn't 
ever the highest priority, so it never gathers resources.  If I flood 
the system with low priority jobs, followed by a high priority PE1 4 (-p 
1000 -pe make 4) job, followed by a less high priority PE1 4 (-p 100 -pe 
make 4) job with reservation (-R y), the reservation job will collect 
resources, eventually allowing the *non-reservation* job to run.  That's 
a problem.  It only happens when both jobs ask the for the same PE with 
the same number of slots, but they don't have to be beside each other in 
the job sort order.  If, for example I submit a PE1 4 job followed by a 
PE2 4 (or PE1 3)  job followed by a PE1 4 job with reservation, the 
third job will immediately start gathering resources, allowing the first 
job (and potentially the second job) to run before the third.

2) Sometimes, a single resource reservation job never collects 
resources.  In those cases, submitting a second job which requests the 
same PE with the same number of slots will push the first job through.  
Last week I was able to reproduce this problem 100% of the time.  Since 
then I have rebooted my machine, and I am no longer able to reproduce 
it, so I cannot offer more insight.

Anyone care to comment before I submit an issue?

Daniel

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list