[GE users] shepard exits with exit code 11

Ravi Chandra Nallan Ravichandra.Nallan at Sun.COM
Tue Jun 12 09:07:48 BST 2007


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Again, check qmaster messages.

use qsh -display ( man qsh)

-Ravi

Jerry Mersel wrote:
> You were correct xterm was not in the correct path.
> I put a link to the correct path and now the job gets run but nothing opens.
>
> Perhaps I have to set the display on the command line to qsh
> How can I do that.
>
>                               Regards,
>                                 JErry
>
>
>   
>> Is the path correct of xterm in qconf -sconf and qconf -sconf <host>?
>> What is in the messages of qmaster?
>>
>> -Ravi
>>
>> Jerry Mersel wrote:
>>     
>>> Hi:
>>>
>>>   qstat gave:
>>>
>>>    queue all.q marked QERROR as result of job 5633's failure at host
>>>
>>>   in the message file for the particular host I got:
>>>
>>>    shepherd of job 5633.1 exited with exit status = 11
>>>
>>>   qsh returned:
>>>
>>> Your job 5633 ("INTERACTIVE") has been submitted
>>> waiting for interactive job to be scheduled ...
>>> Could not start interactive job.
>>>
>>>
>>> Could it have something to do with the version of the OS Redhat AS 5
>>> has GLIBC of 2.5. But then again when I used qrsh and openned xterm
>>> from the host everything worked fine.
>>>
>>>
>>>                                 Thanks,
>>>                                   Jerry
>>>
>>>
>>>
>>>
>>>       
>>>> Any hints in the messages (qmaster/messages, execd's messages on the
>>>> failed host).
>>>> Try,
>>>>   qstat -explain E
>>>> (mostly would have been set to error because of jobs failure).
>>>>
>>>> Also what did the command qsh return (did the job get scheduled?)
>>>>
>>>> -Ravi
>>>>
>>>> Jerry Mersel wrote:
>>>>
>>>>         
>>>>> Hi:
>>>>>
>>>>>   I am running SGE 6.0U8. One of the nodes is running Redhat AS 5.
>>>>>   When I use qrsh -q .q at host it goes to the host no problem.
>>>>>
>>>>>   When I use qsh -q .q at host The host has a "E" attached to the q.host
>>>>>   and the shepard exits with exit code 11.
>>>>>
>>>>>   What is exit code 11?
>>>>>
>>>>>   If I use qrsh and then run xterm it runs fine.
>>>>>
>>>>>                                  Regards,
>>>>>                                    Jerry
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>>>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>>>>
>>>>>
>>>>>
>>>>>           
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>>>
>>>>
>>>>
>>>>         
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>>
>>>
>>>       
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>
>>
>>     
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list