[GE users] enhanced queue configuration specifier syntax

Reuti reuti at staff.uni-marburg.de
Mon Jun 18 15:33:54 BST 2007


Am 18.06.2007 um 15:25 schrieb Paul MacInnis:

> I'm having trouble with the "enhanced queue configuration specifier
> syntax" described in the man page queue_conf.
>
> The problem comes when I try to set multiple criteria for
> "load_thresholds" using qconf on a cluster queue:
>
> np_load_avg=1.5,mem_used=500M,[@2g48h.hg=mem_used=1.5G], \
> [@2g96h.hg=mem_used=1.5G],[@4g48h.hg=mem_used=3.5G], \
> [@4g96h.hg=mem_used=3.5G]

You can set more than one limit for any group, hence e.g.:

[@2g48h.hg=np_load_avg=1.5,mem_used=1.5G]

Do you have more slots than cores for a machine? Maybe the  
np_load_avg threshold can be disregarded completely in your setup.

-- Reuti


> Here's what I want:
> For all nodes, np_load_avg=1.5
> For 1G nodes, mem_used=500M,
> For 2G nodes, mem_used=1.5G,
> For 4G nodes, mem_used=3.5G
>
> qconf accepts the above syntax.
>
> If I then ask to see the configuration for a particular host
> group or a particular host, for load_thresholds it shows only
> the mem_used parameter (with the correct value for the host group
> or node) and the np_load_avg parameter is missing completely.
>
> If I ask to see the configuration for the cluster queue, both
> parameters appear exactly as I set them.
>
> Have I misunderstood something here?
>
> Paul
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list